This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 70969 - Network interface shutdowns randomly
Summary: Network interface shutdowns randomly
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-07 13:45 UTC by Need Real Name
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 13:56:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-07 13:45:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020801

Description of problem:
Sometimes (mostly in night about 23h but it could be just accident) network
interface gets shutdown with this message in /var/log/messages:

Aug  5 23:29:42 localhost network: Shutting down interface eth0:  succeeded
Aug  5 23:29:43 localhost network: Shutting down loopback interface:
succeeded
Aug  5 23:29:43 localhost /etc/hotplug/net.agent: NET unregister event not
supported
Aug  5 23:29:43 localhost kernel: PCI: Found IRQ 10 for device 00:0d.0
Aug  5 23:29:43 localhost kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Aug  5 23:29:43 localhost kernel: 00:0d.0: 3Com PCI 3c905C Tornado at
0xdc00. Vers LK1.1.16

This happens on two different machines (one using 3Com, other one using e1000 +
sis900). When I recompiled kernel (RH 7.3 2.4.18 + XFS patch) with different
options it stopped. I suspect that helped when I turned off "hotplug" options at
all.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:


Additional info:

Comment 1 Arjan van de Ven 2002-08-07 13:47:32 UTC
what exact kernel version are you using?

Comment 2 Need Real Name 2002-08-07 13:56:14 UTC
I'm using default RH 7.3 kernel (2.4.18-4) with XFS support
(2.4.18-4SGI_XFS_1.1). I'm using default kernel as it comes. When I recompile it
with some features disabled (like hotplug) it doesn't appear any more. As it is
production system I cannot do any more tests and on my test system this error
doesn't appear.

Comment 3 Arjan van de Ven 2002-08-07 13:57:39 UTC
Please report bugs in the SGI Linux kernel to SGI, not us.

Comment 4 Need Real Name 2002-08-07 14:04:42 UTC
Sorry, but I disagree - this error seems to be connected to hotplug and/or
network part of the system. Even on one system I was forced stop using XFS (some
little bug in endian conversion causing file corruption when copying large
amounts of files and data) and this error was still occuring. Also when I left
XFS compiled in and turned off another parameters (like I mention - hotplug
support) the error disappeared.

I know it's almost impossible to reproduce this bug so I don't expect it to be
solved - just wanted to make a bugzilla record in case somebody else comes to
this problem also.


Note You need to log in before you can comment on or make changes to this bug.