Bug 709840 - Web Services Tests Do Not Compile
Web Services Tests Do Not Compile
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity low (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-01 14:46 EDT by Stefan Negrea
Modified: 2014-05-06 13:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-06 13:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stefan Negrea 2011-06-01 14:46:11 EDT
Web Services tests do not compile correctly because the code was not maintained. Even if compilable, the tests might not have good coverage for the functionality.
Comment 1 Heiko W. Rupp 2011-06-01 14:54:13 EDT
The whole webservices stuff is not really portable, as it makes an assumption about the location of javac or rt.jar (forgot what exactly) being in /usr/bin and that this directory is writable. This is at least not true on OS X and I would not expect /usr being writable for everyone on other Linux or Unix systems as well.
Comment 2 Stefan Negrea 2014-05-06 13:31:26 EDT
No longer applicable.

Note You need to log in before you can comment on or make changes to this bug.