Bug 70996 - APC BackUPS detected as joystick
APC BackUPS detected as joystick
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: hotplug (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 13:52 EDT by Markku Kolkka
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-08 19:10:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb -vv output for the UPS (1.93 KB, text/plain)
2002-08-07 13:54 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2002-08-07 13:52:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
When I connect the USB cable from my APC BackUPS ES500, the device is detected
but apparently hotplug thinks it's a joystick not an UPS, and as a result the
hidups driver from nut can't open /dev/usb/hiddev0.

Version-Release number of selected component (if applicable):
hotplug-2002_04_01-9

How reproducible:
Always

Steps to Reproduce:
1.Connect USB cable from UPS
2.hidups /dev/usb/hiddev0 (or service ups start)
3.
	

Actual Results:  /var/log/messages shows:
Aug  7 16:25:50 212-246-156-101 kernel: hub.c: USB new device connect on bus2/3,
assigned device number 2
Aug  7 16:25:50 212-246-156-101 kernel: hiddev0: USB HID v1.00 Joystick
[American Power Conversion Back-UPS ES/CyberFort 500 FW: 4.1.I USB FW: d1] on
usb2:2.0
Aug  7 16:25:53 212-246-156-101 /etc/hotplug/usb.agent: Setup hid for USB
product 51d/2/100

hidups fails with:
hiddev open /dev/usb/hiddev0: Permission denied

Expected Results:  The UPS becomes available as /dev/usb/hiddev0, hiddev and nut
works.

Additional info:
Comment 1 Markku Kolkka 2002-08-07 13:54:37 EDT
Created attachment 69324 [details]
lsusb -vv output for the UPS
Comment 2 Trond Eivind Glomsrxd 2002-08-08 17:13:50 EDT
Which modules are loaded on the system? It looks like only hid, in which case
hotplug is doing its thing alright... note that read permissions on the device
for non-root users is a separate issue.
Comment 3 Markku Kolkka 2002-08-08 17:21:43 EDT
_root_ gets the "permission denied" error! If hotplug works correctly, is this a
bug in nut?
loaded modules:
Module                  Size  Used by    Not tainted
loop                   12024   0  (unused)
sr_mod                 17944   0  (autoclean)
es1371                 30536   1  (autoclean)
ac97_codec             13320   0  (autoclean) [es1371]
gameport                3444   0  (autoclean) [es1371]
soundcore               6468   4  (autoclean) [es1371]
r128                   92984  16
agpgart                42976   3
it87                    8900   0  (unused)
i2c-proc                9136   0  [it87]
i2c-isa                 1896   0  (unused)
i2c-core               19332   0  [it87 i2c-proc i2c-isa]
binfmt_misc             7460   1
parport_pc             18980   1  (autoclean)
lp                      8996   0  (autoclean)
parport                37024   1  (autoclean) [parport_pc lp]
sd_mod                 13616   0  (autoclean) (unused)
8139too                17608   1
mii                     2172   0  [8139too]
ipt_REJECT              3704   6  (autoclean)
iptable_filter          2412   1  (autoclean)
ip_tables              14648   2  [ipt_REJECT iptable_filter]
ide-scsi               10544   1
scsi_mod              106760   3  [sr_mod sd_mod ide-scsi]
ide-cd                 33316   0
cdrom                  32992   0  [sr_mod ide-cd]
mousedev                5492   1
keybdev                 2976   0  (unused)
hid                    22052   0  (unused)
input                   5888   0  [mousedev keybdev hid]
usb-ohci               21096   0  (unused)
usbcore                76672   1  [hid usb-ohci]
ext3                   87240   6
jbd                    52148   6  [ext3]
mbcache                 6608   1  [ext3]
Comment 4 Trond Eivind Glomsrxd 2002-08-08 19:10:20 EDT
OK, so this is not a hotplug issue. Could check if root can read or if nut just
tries to access it as another user?
Comment 5 Markku Kolkka 2002-08-09 06:01:10 EDT
hidups runs as "nobody", so I must give world read/write rights to
/dev/usb/hiddev0 (bad idea). I'm closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.