Bug 71000 - mgetty won't work for serial console
mgetty won't work for serial console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mgetty (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 14:17 EDT by Marc MERLIN
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-14 15:38:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 2002-08-07 14:17:24 EDT
Quite frankly, I didn't want to be using mgetty in the first place. It's 10
times too complex when all you need/want is a simple serial console setup,
but since you unfortunately have removed the old and trusty getty_ps from
the distribution...

Inittab says:
S0:S123:respawn:/sbin/mgetty ttyS0

mgetty.config says:
# Dumb serial connection
port ttyS0
 debug 3
 speed 38400
 direct yes
 data-only yes
 toggle-dtr yes
 need-dsr yes
 port-owner root
 port-group root
 port-mode 600
 login-prompt @ \P login:\040
 login-time 60
 term vt102

Output on the serial console is inconsistent:
------------------------------------------------
Red Hat Linux release 7.3 (Valhalla)
Kernel 2.4.18-5smp on an i686       
                             

Red Hat Linux release 7.3 (Valhalla)ogin: 
Kernel 2.4.18-5smp on an i686       
                             

deeptought.engr.intransa.com ttyS0 login:
------------------------------------------------

What I type doesn't get echoed, but it does go somewhere because validating
with enter eventually generates a new prompt and the following errors in the
log:
(note that a) I have tested the serial console with minicom on both sides
and it works fine  b) I am using serial console in the kernel, but with getty_ps
there was no problem having serial console in the kernel + getty running)

08/07 10:32:51 yS0  mgetty: experimental test release 1.1.28-Jan10
08/07 10:33:03 ##### failed dev=ttyS0, pid=1916, got signal 1, exiting

--
08/07 10:33:03 yS0  mgetty: experimental test release 1.1.28-Jan10
08/07 10:33:04 yS0  TIOCMBIS failed: Input/output error
08/07 10:33:04 yS0  cannot turn off soft carrier: Input/output error
08/07 10:33:04 yS0  tcgetattr failed: Input/output error
08/07 10:33:04 yS0  cannot get TIO: Input/output error
08/07 10:33:04 yS0  mg_init_device failed, trying again
08/07 10:33:05 yS0  TIOCMBIS failed: Input/output error
08/07 10:33:05 yS0  cannot turn off soft carrier: Input/output error
08/07 10:33:05 yS0  tcgetattr failed: Input/output error
08/07 10:33:05 yS0  cannot get TIO: Input/output error
08/07 10:33:05 yS0  mg_init_device failed, exiting: Input/output error
08/07 10:33:05 yS0  cannot get terminal line dev=ttyS0, exiting: Input/output error
Comment 1 Marc MERLIN 2002-08-07 17:02:30 EDT
Just to confirm that things are working otherwise, I copied over my getty
from debian (util-linux) and that worked fine.
I also got it to work with getty_ps from RHL 7.0, but you're retired this
package...
Comment 2 Jason Vas Dias 2005-06-14 15:37:50 EDT
Just clearing out old bugs here - sorry for the delay in processing
this one - it seems to have been "lost" .

I've just retested this with mgetty-1.1.31-2 and 1.1.33-1 (mgetty is
no longer "experimental"), with the mgetty.config entry:
'
  port ttyS0
      direct y
      speed 57600
      toggle-dtr n
'
and with a null modem cable to another computer and the kernel-2.6.11
arguments 'console=ttyS0,57600 console=tty0', and the /etc/inittab
line: 'S0:2345:respawn:/sbin/mgetty ttyS0' .

The console connection worked flawlessly and let me log-in (as root,
when I had added ttyS0 to /etc/securettys).

There is also now agetty(8), which along with mgetty and mingetty
should be enough to replace getty_ps .

So this bug is closed as CURRENTRELEASE, as it appears to be fixed
with all current versions of mgetty.

Note You need to log in before you can comment on or make changes to this bug.