Bug 71019 - -ivh progress bar stops at 97%
Summary: -ivh progress bar stops at 97%
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm   
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-07 20:44 UTC by Michael Schwendt
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-07 20:44:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2002-08-07 20:44:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
Not related to terminal width.

With rpm-4.1-0.69 and the kernel-source I got a progress bar that -- when
installation is finished -- ends at 97% with the bash prompt overwriting rpm's
last line because rpm didn't seem to write a line with linefeed to finish its
last line of output:

[root@faldor home]# rpm -ivh kernel-source-2.4.18-7.93.i386.rpm
warning: kernel-source-2.4.18-7.93.i386.rpm: Header V3 DSA signature: NOKEY, key
ID 897da07a
Preparing...                ########################################### [100%]
   1:kernel-source          ######### ( 22%)

And at the end of installation:

[root@faldor home]# rpm -ivh kernel-source-2.4.18-7.93.i386.rpm
warning: kernel-source-2.4.18-7.93.i386.rpm: Header V3 DSA signature: NOKEY, key
ID 897da07a
Preparing...                ########################################### [100%]
[root@faldor home]#         ##########################################  ( 97%)

And the cursor one space after the '#'.

I did expect it to end at 100% with the last lines reading:

Preparing...                ########################################### [100%]
   1:kernel-source          ########################################### [100%]

Version-Release number of selected component (if applicable):
4.1-0.69

How reproducible:
Always

Comment 1 Jeff Johnson 2002-08-07 21:53:08 UTC
Rounddown float-to-int truncation error, "+ 0.5" added where needed.
Should be fixed in rpm-4.1-0.76 when built.


Note You need to log in before you can comment on or make changes to this bug.