Bug 710193 - Rebase request for crash utility RHEL6.2 errata
Rebase request for crash utility RHEL6.2 errata
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: crash (Show other bugs)
6.2
All Linux
high Severity high
: rc
: ---
Assigned To: Dave Anderson
Kernel Dump QE
: Rebase
Depends On:
Blocks: 692799 743047 784700
  Show dependency treegraph
 
Reported: 2011-06-02 12:05 EDT by Dave Anderson
Modified: 2012-01-25 15:25 EST (History)
4 users (show)

See Also:
Fixed In Version: crash-5.1.8-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump and virsh dump facilities. With this update, Crash has been rebased to upstream version 5.1.8. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 11:30:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2011-06-02 12:05:59 EDT
Description of problem:

The RHEL6.2 errata version of crash should be rebased to the current
upstream version of the crash utility.

It is far more efficient, and far safer, to rebase to the upstream 
version than to attempt to selectively backport the patches required for
the current set of bugzillas requested for RHEL6.2.  Furthermore, the new
features and other fixes that have been applied to the upstream version 
make the tool significantly more useful than the current RHEL6 version.
It should also be noted that RHEL6 MRG-RT kernel does not work with the
current RHEL6 version of the crash utility because of the later kernel
version it uses, and requires the upstream version.

As the owner and upstream maintainer, one of my primary goals is, and
always has been, to maintain backwards-compatibility whenever new fixes
or features are applied.  Therefore the risk of regression is less with a
rebase than it would be with selective backports because the RHEL6.2
bugzilla-requested fixes are based upon the state of the upstream version. 

It should be noted that nothing goes into the upstream version without
my approval, and my testing.  I perform all my testing on RHEL6 systems,
and test changes against a sample set of RHEL3, RHEL4, RHEL5, upstream
and Fedora kernel crash dumps.

Details regarding recent fixes, features and enhancements can be found in:

  http://people.redhat.com/anderson/crash.changelog.html


Version-Release number of selected component (if applicable):

  crash-5.1.1-2.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Dave Anderson 2011-06-02 13:35:36 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
and virsh dump facilities.

With this update, Crash has been rebased to upstream version 5.1.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 7 Dave Anderson 2011-08-02 15:22:09 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
 The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
 and virsh dump facilities.
 
-With this update, Crash has been rebased to upstream version 5.1.x. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html+With this update, Crash has been rebased to upstream version 5.1.7. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 8 Dave Anderson 2011-09-19 14:17:59 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,4 +1,4 @@
 The crash packages are used to investigate live systems and kernel core dumps created from the netdump, diskdump, kdump
 and virsh dump facilities.
 
-With this update, Crash has been rebased to upstream version 5.1.7. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html+With this update, Crash has been rebased to upstream version 5.1.8. For a complete list of bug fixes and enhancements, refer to the upstream changelog at http://people.redhat.com/anderson/crash.changelog.html
Comment 10 errata-xmlrpc 2011-12-06 11:30:04 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1648.html

Note You need to log in before you can comment on or make changes to this bug.