Bug 71038 - mailman requires sendmail, postfix won't meet dependencies.
mailman requires sendmail, postfix won't meet dependencies.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-07 22:21 EDT by Michael Fratoni
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-26 08:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Fratoni 2002-08-07 22:21:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Installing mailman-2.0.9-1 on a system using postfix as the MTA fails with
unsatisfied dependencies for /usr/bin/newaliases. Sendmail is the only package
which has that file as a 'provides'.

Version-Release number of selected component (if applicable):
mailman-2.0.9-1

How reproducible:
Always

Steps to Reproduce:
1.Install postfix as the only MTA.
2.Attempt to install mailman
3.
	
Actual Results:  Unmet dependency on /usr/bin/newaliases

Expected Results:  Install without complaint.

Additional info:

rpm -q --requires mailman | grep alias
/usr/bin/newaliases

rpm -q --provides postfix | grep newalias
/usr/bin/newaliases.postfix

rpm -q --provides sendmail | grep newalias
/usr/bin/newaliases

Perhaps the solution is for mailman to require "smtpdaemon". I would have
suggested MTA, but this is actually another oddity, as sendmail provides only:
smtpdaemon
/usr/sbin/sendmail
/usr/bin/mailq
/usr/bin/newaliases
/usr/bin/rmail

While postfix provides:
MTA
smtpd
smtpdaemon
/usr/sbin/sendmail
/usr/bin/mailq
/usr/bin/rmail
Comment 1 Chris Ricker 2003-04-26 08:49:22 EDT
Closing this as fixed, since mailman + postfix w/o sendmail does install
correctly on RHL 9

Note You need to log in before you can comment on or make changes to this bug.