This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 710520 - Message TTL not adjusted correctly for messages about to expire
Message TTL not adjusted correctly for messages about to expire
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.3
Unspecified Unspecified
high Severity unspecified
: 3.0
: ---
Assigned To: Gordon Sim
Leonid Zhaldybin
: Patch
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2011-06-03 11:30 EDT by Andy Goldstein
Modified: 2014-11-09 17:38 EST (History)
5 users (show)

See Also:
Fixed In Version: qpid-0.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-24 11:03:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-3291 None None None 2012-11-14 15:03:33 EST

  None (edit)
Description Andy Goldstein 2011-06-03 11:30:18 EDT
See https://issues.apache.org/jira/browse/QPID-3291 for details and proposed patch
Comment 1 Gordon Sim 2011-06-03 12:06:47 EDT
Andy's fix committed upstream: http://svn.apache.org/viewvc?rev=1131084&view=rev
Comment 7 Leonid Zhaldybin 2013-12-19 03:59:20 EST
Tested on RHEL6.5 (both i386 and x86_64). This issue has been fixed.

Packages used for testing:

python-qpid-0.22-8.el6
python-qpid-qmf-0.22-24.el6
qpid-cpp-client-0.22-29.el6
qpid-cpp-client-devel-0.22-29.el6
qpid-cpp-client-devel-docs-0.22-29.el6
qpid-cpp-client-rdma-0.22-29.el6
qpid-cpp-client-ssl-0.22-29.el6
qpid-cpp-server-0.22-29.el6
qpid-cpp-server-devel-0.22-29.el6
qpid-cpp-server-ha-0.22-29.el6
qpid-cpp-server-rdma-0.22-29.el6
qpid-cpp-server-ssl-0.22-29.el6
qpid-cpp-server-store-0.22-29.el6
qpid-cpp-server-xml-0.22-29.el6
qpid-proton-c-0.5-9.el6
qpid-qmf-0.22-24.el6
qpid-tools-0.22-7.el6

-> VERIFIED
Comment 9 errata-xmlrpc 2014-09-24 11:03:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html

Note You need to log in before you can comment on or make changes to this bug.