Bug 71109 - Printing on PhotoSmart 1115VM hangs
Printing on PhotoSmart 1115VM hangs
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-08 16:38 EDT by Christopher A. Williams
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 12:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher A. Williams 2002-08-08 16:38:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
Printconf-gui can not print to HP PhotoSmart 1115 printer using hpijs (or any
other) supplied drivers. Detailed description of problem, and what I have done
to look at it so far is attached.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure HP PhotoSmart 1115VM using printconf-gui
2. Print a test page (ASCII or PostScript)
3. Printer does not print anything at all - job gets saved as a non-printable
queued job.
	

Actual Results:  Printer does not print anything at all - job gets saved as a
non-printable queued job.

Expected Results:  Properly printer test pages and ability to print from
applications.

Additional info:
After creating a printer queue using the HPIJS driver, printing doesn't work at
all. Following are the errors from the status.pr file.

IF filter 'mf_wrapper' filter msg - 'gs  PID pid2=4590' at
2002-08-08-10:13:59.640 ## A=root@spike+573 number=573 process=4575 
IF filter 'mf_wrapper' filter msg - 'foomatic-gswrapper: gs '-dBATCH' '-dSAFER'
'-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs'
'-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=PHOTOSMART 1115'
'-dDEVICEWIDTHPOINTS=612' '-dDEVICEHEIGHTPOINTS=792'
'-sIjsParams=Quality=0,ColorMode=2,MediaType=0,PenSet=2' '-r300' '-dDuplex=0'
'-sOutputFile=/dev/fd/3' '/dev/fd/0' 3>&1 1>&2' at 2002-08-08-10:13:59.649 ##
A=root@spike+573 number=573 process=4575 
IF filter 'mf_wrapper' filter msg - 'Unrecoverable error: typecheck in
.putdeviceprops' at 2002-08-08-10:14:00.790 ## A=root@spike+573 number=573
process=4575 
IF filter 'mf_wrapper' filter msg - 'Couldn't exec foomatic-gswrapper -q -dBATCH
-dSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs
-sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="PHOTOSMART 1115"
-dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792
-sIjsParams="Quality=0,ColorMode=2,MediaType=0,PenSet=2" -r300 -dDuplex=0
-sOutputFile=- - at /usr/sbin/lpdomatic line 778.' at 2002-08-08-10:14:00.797 ##
A=root@spike+573 number=573 process=4575 

If I issue the command (copied and pasted as root to the command line from the
above): 
foomatic-gswrapper -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs
-sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD"
-sDeviceModel="PHOTOSMART 1115" -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792
-sIjsParams="Quality=0,ColorMode=2,MediaType=0,PenSet=2" -r300 -dDuplex=0
-sOutputFile="/dev/lp0" /usr/share/printconf/tests/testpage.ps 

The RH 7.3 PostScript test page prints a little more than halfway and then
stops. Everything just hangs. 

If I change the driver in printconf-gui to "Text Only Printer" and send an ASCII
test page, the printer loads a page and then eventually errors out with a "PC
Data Was Not Received" message on its display. If I then hit the printer's OK
button, the test page prints. 

On a suggestion from the vahalla support forum, I tried the following:
I upgraded to GhostScript 7.05, Omni (Omni-0.7.0-4 and Omni-foomatic-0.7.0-4),
gimp-print (gimp-print-4.2.1-5 and gimp-print-devel-4.2.1-5), HPIJS 1.2 and the
latest foomatic per instructions at the HP InkJet site (at
http://hpinkjet.sourceforge.net). I had to install / update both Omni and
gimp-print to be able to upgrade GhostScript to 7.05 via RPM. Now the following
happens: 

Using the "Text Only Printer" driver as before produces the same results - the
"PC Data Was Not Received" message. Pressing OK then allows the page to print. 

Using the HPIJS driver for the PhotoSmart P1115: 
The RedHat PostScript test page refuses to print at all. Error info from the
status.pr file is: 

IIF filter 'mf_wrapper' filter msg - 'Last OS error: 2' at
2002-08-08-10:46:55.680 ## A=root@spike+574 number=574 process=5576 
IF filter 'mf_wrapper' filter msg - 'GNU Ghostscript 6.53: Unrecoverable error,
exit code 1' at 2002-08-08-10:46:55.680 ## A=root@spike+574 number=574 process=5576 
IF filter 'mf_wrapper' filter msg - 'Couldn't exec foomatic-gswrapper -q -dBATCH
-dSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs
-sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="PHOTOSMART 1115"
-dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792
-sIjsParams="Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=2"
-r300 -dDuplex=false -dIjsUseOutputFD -sOutputFile=- - at /usr/sbin/lpdomatic
line 778.' at 2002-08-08-10:46:55.687 ## A=root@spike+574 number=574 process=5576 

Turning debug on in the lpdomatic script just places the same errors in
/tmp/lpdomatic.log. 

Note the unrecoverable error being reported refers to GhostScript version 6.53 -
despite that GS 7.05 is now installed and verified to be there AND GhostScript
6.53 was never there at all because RH7.3 apparently uses a modified GhostScript
6.52. Moreover, if I paste the contents of the foomatic-gswrapper command to the
command line as root, direct it to /dev/lp0 and point specifically to the RH 7.3
PostScript test page as below: 

foomatic-gswrapper -q -dBATCH -dSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs
-sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD"
-sDeviceModel="PHOTOSMART 1115" -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792
-sIjsParams="Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=2"
-r300 -dDuplex=false -dIjsUseOutputFD -sOutputFile=/dev/lp0
/usr/share/printconf/tests/testpage.ps 

The RH 7.3 PostScript test page prints PERFECTLY! 

foomatic-gswrapper delivers the following output to the screen in the process: 

foomatic-gswrapper: gs '-dBATCH' '-dSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs'
'-sIjsServer=hpijs' '-sDeviceManufacturer=HEWLETT-PACKARD'
'-sDeviceModel=PHOTOSMART 1115' '-dDEVICEWIDTHPOINTS=612'
'-dDEVICEHEIGHTPOINTS=792'
'-sIjsParams=Quality:Quality=0,Quality:ColorMode=2,Quality:MediaType=0,Quality:PenSet=2'
'-r300' '-dDuplex=false' '-dIjsUseOutputFD' '-sOutputFile=/dev/lp0'
'/usr/share/printconf/tests/testpage.ps' 3>&1 1>&2 

Finally, I installed the hpoj drivers (hpoj-0.8) rom the HP OfficeJet project
(http://hpoj.sourceforge.net), which bypass the standard /dev/lp0 port and
replace it with a /dev/ptal-printd/mlc_par_0 port instead. I then deleted and
re-created the queue in print-conf-gui to point to this device. Now what happens
is the following: 

Using the "Text Only Printer" driver, the ASCII test page prints PERFECTLY! 

Using the HPIJS driver, the printer refuses to print. I get EXACTLY the same
errors in the status.pr file as before. 

Issuing the offending foomatic-gswrapper command directly to
/dev/ptal-printd/mlc_par_0 still works PERFECTLY! 

My suspicion (conclusion): Something in foomatic - quite possibly lpdomatic or
something working with it - is definitely screwball and something (possibly also
in GS 6.52 from RH 7.3) may be affecting the way things get sent to the printer,
causing the whole thing to get stuck. The hpoj drivers seem to get around this
problem, but I think that may be addressing a symptom as opposed to the problem
since foomatic-gswrapper works using GS 7.05 without the hpoj drivers. 

Bottom line: I still can't print!
Comment 1 Tim Waugh 2002-08-09 13:06:59 EDT
Couldn't reproduce this problem on 7.3+updates when sending print output to a 
local file.  Test output file sent in private mail.
Comment 2 Tim Waugh 2005-09-16 12:38:33 EDT
No feedback.

Note You need to log in before you can comment on or make changes to this bug.