Bug 71114 - crash when opening network configuration
crash when opening network configuration
Status: CLOSED DUPLICATE of bug 69320
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-08 17:37 EDT by paul cooper
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 11:48:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paul cooper 2002-08-08 17:37:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
crash when opening network configuration - unable to change config

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cp
2.network configuration
3.
 

Actual Results:  'exception occured'

Expected Results:  nw confgi shouyld have opened

Additional info:

raceback (innermost last):
  File "/usr/sbin/neat", line 1398, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 222, in __init__
    self.load()
  File "/usr/sbin/neat", line 243, in load
    self.loadProfiles()
  File "/usr/sbin/neat", line 256, in loadProfiles
    profilelist = getProfileList()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py", line 393, in getProfileList
    PFList.load()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCProfileList.py", line 44, in load
    hoconf = Conf.ConfEHosts()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 429, in __init__
    Conf.__init__(self, '/etc/hosts')
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 180, in __init__
    self.read()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 432, in read
    self.initvars()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 445, in initvars
    raise BadFile, 'Malformed /etc/hosts file'
Conf.BadFile: Malformed /etc/hosts file

Local variables in innermost frame:
self: <netconfpkg.Conf.ConfEHosts instance at 84f3788>
var: ['\015']
Comment 1 Josef Komenda 2002-08-14 15:22:04 EDT
I tend to think that this is a problem with Red Hat's Network Configuration
tools rather than Red Hat Network's configuration tools. Over to the OS folks.
Comment 2 Cristian Gafton 2002-08-15 01:31:40 EDT
assigned to teg
Comment 3 Harald Hoyer 2002-10-18 11:11:05 EDT

*** This bug has been marked as a duplicate of 69320 ***

Note You need to log in before you can comment on or make changes to this bug.