This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 711173 - strange behavior of xmonad
strange behavior of xmonad
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xmonad (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Boeckel
Fedora Extras Quality Assurance
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-06 13:51 EDT by Pavel Zhukov
Modified: 2011-08-02 15:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-02 15:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xmonad,hs (5.44 KB, application/octet-stream)
2011-06-10 15:43 EDT, Pavel Zhukov
no flags Details

  None (edit)
Description Pavel Zhukov 2011-06-06 13:51:42 EDT
Description of problem:
xmonad freezes sometimes.

Version-Release number of selected component (if applicable):
xmonad-0.9.2-8.fc15.x86_64

How reproducible:
work in xmonad. sometimes I cannot change layouts. resize windows or something else. But other applications work perfectly (firefox or rxvt for example). 

Steps to Reproduce:
hard to reproduce.

Additional info:
How can I debug this? There are not errors in Xorg.0.log or messages.
Xmonad on F14 with the same config works perfectly.
Comment 1 Jens Petersen 2011-06-06 20:37:07 EDT
Are you using a desktop?  And xmonad-contrib?
This is the first time I hear of problems with xmonad-0.9.2.

Any errors in ~/.xsession-errors?

Perhaps you can try to rebuild the f14 xmonad package(s) for f15
and see if your problem still happens.

Otherwise can you attach your xmonad.hs if you have configured one?
Comment 2 Pavel Zhukov 2011-06-06 23:41:07 EDT
I'm using cdm login manager. xmonad + xmobar + xmobar-contrib 
cat: /home/pavel/.xsession-errors: No such file or directory

I haven't any problems before (I use xmonad for 2 years).

rpm -qa | grep xmonad
ghc-xmonad-contrib-0.9.2-3.fc15.x86_64
xmonad-core-0.9.2-8.fc15.x86_64
ghc-xmonad-0.9.2-8.fc15.x86_64
ghc-xmonad-devel-0.9.2-8.fc15.x86_64
xmonad-0.9.2-8.fc15.x86_64
ghc-xmonad-contrib-devel-0.9.2-3.fc15.x86_64
Comment 3 Jens Petersen 2011-06-07 00:41:27 EDT
(In reply to comment #0)
> work in xmonad. sometimes I cannot change layouts. resize windows or something
> else. But other applications work perfectly (firefox or rxvt for example). 

Does your problem happen with the default xmonad configuration?
Comment 4 Pavel Zhukov 2011-06-09 13:05:02 EDT
I cannot test with default config at the moment (hard-working). 

Some additions: If I have opened two (or more) open windows at the same workspace I cannot switch input from one to another (by mouse for example). But current application (window) works.
Comment 5 Jens Petersen 2011-06-09 23:14:41 EDT
Perhaps you could attach your xmonad.hs and a screenshot if it helps?
Comment 6 Pavel Zhukov 2011-06-10 15:43:57 EDT
Created attachment 504196 [details]
xmonad,hs
Comment 7 Pavel Zhukov 2011-06-10 15:53:36 EDT
I cannot make screenshot when xmonad doesn't response...
Comment 8 Ben Boeckel 2011-06-10 16:53:36 EDT
To get a screenshot, try dropping to a TTY and running:

    DISPLAY=:0 scrot

(or whatever program is normally used).
Comment 9 Pavel Zhukov 2011-06-12 05:22:12 EDT
There are empty black squares (on screenshots). 
But firefox (or other applications as well) is running correctly. After xmonad freeze I opened this bug, read you instruction, switched to tty2, DISPLAY=:0 scrot screen1.png, switched back to X. But I could not open modal windows in FF, for example, or switch between worpspaces/frames. 
~/.xmonad/xmonad.errors is empty.
Comment 10 Jens Petersen 2011-06-13 03:39:24 EDT
(In reply to comment #4)
> I cannot test with default config at the moment (hard-working). 

When you have time this would still be useful information.

> If I have opened two (or more) open windows at the same
> workspace I cannot switch input from one to another (by mouse for example).

How often does it happen?

I just tried your configuration a bit and so far I didn't
notice any problems.
Comment 11 Pavel Zhukov 2011-06-20 13:50:08 EDT
(In reply to comment #10)
> (In reply to comment #4)
> > I cannot test with default config at the moment (hard-working). 
> 
> When you have time this would still be useful information.

2 days with default config. It works!
> 
> > If I have opened two (or more) open windows at the same
> > workspace I cannot switch input from one to another (by mouse for example).
> 
> How often does it happen?
Every 2-3 hours. 
> I just tried your configuration a bit and so far I didn't
> notice any problems.
Comment 12 Jens Petersen 2011-06-21 00:42:33 EDT
I see thanks - interesting.

Well still not sure what change is causing your problem:
ghc or xmonad version change, or something else.

You might want to ask the upstream mailing list
if anyone else has faced your problem.
Comment 13 Pavel Zhukov 2011-06-25 06:25:08 EDT
Just for attention:
I've copied config to my gentoo desktop. There is the same problem.
Comment 14 Jens Petersen 2011-06-27 22:41:44 EDT
I see thanks - then I recommend asking the upstream mailing-list
since this is not fedora specific.
Comment 15 Pavel Zhukov 2011-08-02 15:24:38 EDT
I'm not using xmonad currently. So I close bug.

Note You need to log in before you can comment on or make changes to this bug.