Bug 711493 - Multiple syntax errors in /sbin/new-kernel-pkg
Multiple syntax errors in /sbin/new-kernel-pkg
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-07 12:05 EDT by Jerry James
Modified: 2011-06-07 14:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: grubby-7.0.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 14:35:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2011-06-07 12:05:58 EDT
Description of problem:
I am unable to yum remove a broken kernel on my rawhide machine, because the %preun scriptlet fails due to multiple syntax errors in /sbin/new-kernel-pkg.

First, the shebang at the top is broken.  The first character in the file is 'u', instead of '#'.  Second, on line 111, there is a missing "then" token after the semicolon.  Third, there should be no parentheses after "run_grub2" on lines 149, 220, and 272.

Version-Release number of selected component (if applicable):
grubby-7.0.17-1.fc16.x86_64
grubby-7.0.17-1.fc16.i686

How reproducible:
Always

Steps to Reproduce:
1. yum remove kernel-3.0-0.rc1.git0.1.fc16.x86_64
2.
3.
  
Actual results:
The package is not removed due to errors in the PREUN scriptlet.  Running the script by hand reveals the problem to be the syntax errors noted above.

Expected results:
Package removal.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.