This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 711657 - The printable GUI can't show correctly
The printable GUI can't show correctly
Status: CLOSED DEFERRED
Product: TCMS
Classification: Other
Component: Web UI (Show other bugs)
3.4.1
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: nli
tools-bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-08 01:03 EDT by Xin Gao
Modified: 2015-05-27 18:37 EDT (History)
11 users (show)

See Also:
Fixed In Version: 3.5.0-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-26 01:33:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
print_UI is not clear (120.86 KB, image/png)
2011-06-08 01:03 EDT, Xin Gao
no flags Details
Printplan (171.54 KB, image/jpeg)
2011-07-15 00:34 EDT, Guoping Feng
no flags Details

  None (edit)
Description Xin Gao 2011-06-08 01:03:15 EDT
Created attachment 503619 [details]
print_UI is not clear

Description of problem:
The printable GUI can't show correctly.

Version-Release number of selected component (if applicable):
3.4-1 on stage

How reproducible:


Steps to Reproduce:
1.Search some plans via advanced search or PLANNING->Search Planning.
2.Click "Printable copy" button above the result list.
  
Actual results:
GUI can't show correctly.
Please refer to attachment

Expected results:
GUI can show correctly.

Additional info:
Comment 1 Chaobin Tang 2011-06-08 07:09:28 EDT
Looked into this, and this brings a bigger problem regarding the printable feature.

The printable version of the plans includes several blocks such as setup, breakdown and others. These informations are input by users, using a rich-text editor THAT PRODUCES HTML CODE along with the text. Then in printable version, the system is trying to output these information and it encounters a paradox -

1. While allowing those HTML code(embedded in setup, breakdown of a plan)to be translated by browser, the printable version will appear disordered, with texts oversize the other, just the way the bug report described.

2. While disabling those naughty HTML code, it works just fine with all texts with the same size, however, the output information will then include those text-translated HTML code such as (<h3></span>...), and it looks just awkward.

The inconsideration of this implication between the input and output was the root cause of this defect of printable feature, it takes a further step for a proper fix.

Not in hot-fix version, effort on that surpasses that allowed.
Comment 2 Jin Zhao 2011-06-09 03:24:35 EDT
keep status "ASSIGNED" in order to track this issue in the future.
Comment 3 Guoping Feng 2011-07-15 00:34:00 EDT
Created attachment 513316 [details]
Printplan
Comment 4 Guoping Feng 2011-07-15 00:40:44 EDT
Verify 3.5.0-1 on stage -->FAIL

Verify steps:
1.Search some plans via advanced search or PLANNING->Search Planning.
2.Click "Printable copy" button above the result list.

Actual results:
GUI can't show correctly. Please refer to the attachment 513316 [details].

Expected results:
GUI can show correctly.

Additional info:
The premise of can't show correctly is that the content of test case in the fields of "Setup", "Breakdown", "Actions", "Expected Results" is too long with no properly changing lines.
Comment 5 Danqing Li 2011-12-26 01:33:40 EST
Deferred to 4.0

Note You need to log in before you can comment on or make changes to this bug.