Bug 71188 - initscripts adds default route per secondary address
initscripts adds default route per secondary address
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-09 14:37 EDT by Daniel Senie
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 14:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2002-08-09 14:37:22 EDT
Description of Problem:

The initscripts are placing a separate default route in the kernel routing 
table for each address in a range. These routes are all identical and 
redundant. This was not the case with RedHat 7.0. Example output of netstat -nr:


Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
172.17.xxx.0    0.0.0.0         255.255.255.0   U        40 0          0 eth1
xxx.xx.xx.0    0.0.0.0         255.255.255.0   U        40 0          0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U        40 0          0 lo
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
0.0.0.0         xxx.xxx.xx.1    0.0.0.0         UG       40 0          0 eth0
Version-Release number of selected component (if applicable):


How Reproducible:

100%

Steps to Reproduce:
1. add a range of IP addresses (in my case, on same subnet as base interface)
2. reboot or restart networking
3. netstat -nr

Actual Results:


Expected Results:

Expected only a single default route, since that is quite sufficient.

Additional Information:
Comment 1 Bill Nottingham 2002-08-13 21:36:12 EDT
This should be fixed in the current rawhide initscripts (6.88-1, or later).

Note You need to log in before you can comment on or make changes to this bug.