Bug 71189 - Throws exception when trying to send a profile with a USB Hub
Summary: Throws exception when trying to send a profile with a USB Hub
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-09 18:39 UTC by ajs
Modified: 2015-01-07 23:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 20:58:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ajs 2002-08-09 18:39:24 UTC
Description of Problem:
When registering, The GUI throws an exception that says:

Problem sending hardware profile:
While running 'registration.add_hw_profile': caught
exceptions.KeyError : ("Don't know how to parse key `usbprod''", {'desc': '"USB
UHCI Root Hub"', 'usbprotocol':
'0', 'usbport': '0', 'usbprod': 'USB UHCI Root Hub', 'class': 'OTHER',
'deviceId': '0000', 'usbsubclass':
'0', 'usbbus': '1', 'usbclass': '9', 'driver': 'unknown', 'bus': 'USB',
'usblevel': '0', 'detached': '0',
'vendorId': '0000'})


Version-Release number of selected component (if applicable):

up2date-2.9.30-7.x.9

Comment 1 Warren Togami 2002-08-11 05:00:48 UTC
This occured to me in update-2.9.38-7.x.9 on my Sony Vaio FXA-36 Athlon laptop.
 I don't have a USB hub.


Comment 2 Chris Runge 2002-08-12 00:32:27 UTC
Similar problem here with up2date-2.9.30-7.x.9 included in Limbo 7.3.93 except
that the problem is with a Microsoft Sidewinder Force Feedback 2 joystick.

Problem sending hardware profile:
While running 'registration.add_hw_profile': caught
exceptions.KeyError : ("Don't know how to parse key `usbprod''", {'desc':
'"Microsoft SideWinder Force
Feedback 2 Joystick"', 'usbprotocol': '0', 'usbprod': 'SideWinder Force Feedback
2 Joystick', 'usblevel':
'2', 'class': 'OTHER', 'deviceId': '001b', 'usbsubclass': '0', 'usbbus': '1',
'usbclass': '3', 'driver':
'unknown', 'detached': '0', 'bus': 'USB', 'usbport': '0', 'usbmfr': 'Microsoft',
'vendorId': '045e'})

-----------

The system did register, but there was no hardware or software information in
the profile.

Comment 3 Adrian Likins 2002-08-12 19:15:00 UTC
This is waiting on some server side updates to go live...

Comment 4 Matt Jamison 2003-05-19 19:12:14 UTC
have those server side updates gone live yet?

Comment 5 Mihai Ibanescu 2003-05-19 21:14:12 UTC
This should be fixed for some time now.


Note You need to log in before you can comment on or make changes to this bug.