This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 71193 - clustat logs "message from unauthorized source... probably a bug!"
clustat logs "message from unauthorized source... probably a bug!"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager (Show other bugs)
2.1
All Linux
low Severity low
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-09 15:23 EDT by Lon Hohberger
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 15:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2002-08-09 15:23:41 EDT
Description of problem:
Sometimes, clustat starts dumping ominous messages to the log file.  This is
caused by clustat having the wrong authentication data after a total cluster
outage (ie, "service cluster stop" on both nodes).  Other side effects are
listed below.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run clustat.
2. Stop the cluster services on both nodes.
3. Restart the cluster services on both nodes.

Actual Results:  - The above log messages
- "output of memcmp: -1" from cluquorumd and clupowerd
- clustat showing "Unknown error 4294967295" for power switch status on one or
both nodes.

Expected Results:  Unspecified at this time.

Additional info:

Restart clustat after a total cluster outage.  Considering making clustat
restart itself after it detects a cluster outage, or at least, reread the
cluster authentication data.
Comment 1 Lon Hohberger 2002-08-14 14:56:02 EDT
Fix for clustat in pool.

Note You need to log in before you can comment on or make changes to this bug.