This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 712079 - Package "at" should depend on chkconfig
Package "at" should depend on chkconfig
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: at (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tomas Mraz
Leos Pol
: EasyFix
Depends On:
Blocks: 691780
  Show dependency treegraph
 
Reported: 2011-06-09 08:54 EDT by Jan Stodola
Modified: 2015-03-26 23:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: at-3.1.10-47.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-19 10:39:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2011-06-09 08:54:57 EDT
Description of problem:
Package "at" runs '/sbin/chkconfig' in postinstall scriplet,
but the package doesn't depend on the chkconfig package:

postinstall scriptlet (using /bin/sh):
touch /var/spool/at/.SEQ
chmod 600 /var/spool/at/.SEQ
chown daemon:daemon /var/spool/at/.SEQ
# must be in chkconfig on
/sbin/chkconfig --add atd

[root@rtt6 ~]# rpm -qf /sbin/chkconfig
chkconfig-1.3.47-1.el6.s390x

[root@rtt6 ~]# rpm -q --requires at | grep chkconfig
[root@rtt6 ~]#

[root@rtt6 ~]# yum --disablerepo=local --installroot=/root/tmp_root install at
Loaded plugins: product-id, subscription-manager
Updating Red Hat repositories.
rhel                                                | 4.0 kB     00:00     
rhel/primary_db                                     | 2.5 MB     00:00     
Setting up Install Process
...
  Installing : coreutils-8.4-13.el6.s390x                        31/33 
  Installing : pam-1.1.1-8.el6.s390x                             32/33 
  Installing : at-3.1.10-43.el6.s390x                            33/33 
Non-fatal POSTIN scriptlet failure in rpm package at-3.1.10-43.el6.s390x
/var/tmp/rpm-tmp.Oy7SZG: line 5: /sbin/chkconfig: No such file or directory
warning: %post(at-3.1.10-43.el6.s390x) scriptlet failed, exit status 127
rhel/productid                                      | 1.7 kB     00:00     
duration: 12(ms)
installing: 72.pem
Installed products updated.
...

Version-Release number of selected component (if applicable):
at-3.1.10-43.el6

How reproducible:
always

Steps to Reproduce:
1. install "at" into new install root, see description
  
Actual results:
...
  Installing : at-3.1.10-43.el6.s390x                            33/33 
Non-fatal POSTIN scriptlet failure in rpm package at-3.1.10-43.el6.s390x
/var/tmp/rpm-tmp.Oy7SZG: line 5: /sbin/chkconfig: No such file or directory
warning: %post(at-3.1.10-43.el6.s390x) scriptlet failed, exit status 127
rhel/productid                                      | 1.7 kB     00:00     
duration: 12(ms)
installing: 72.pem
Installed products updated.

Expected results:
No errors when installing "at"
...
  Installing : at-3.1.10-43.el6.s390x                            33/33 
rhel/productid                                      | 1.7 kB     00:00     
duration: 12(ms)
installing: 72.pem
Installed products updated.
Comment 1 Marcela Mašláňová 2011-06-13 10:24:44 EDT
I suppose if you don't have chkconfig installed, you don't want use it. In that case you can skip scriptlets.
Comment 2 RHEL Product and Program Management 2011-07-05 19:57:48 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 3 Alexander Todorov 2011-08-17 03:57:22 EDT
(In reply to comment #1)
> I suppose if you don't have chkconfig installed, you don't want use it. In that
> case you can skip scriptlets.

Or you can add something like:
Requires(post): chkconfig
Requires(preun): chkconfig
Comment 4 RHEL Product and Program Management 2012-09-07 01:03:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2013-10-13 21:04:18 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Tomas Mraz 2014-12-11 03:47:16 EST
There are also other ommitments in Requires(post) and superfluous BuildRequires. I will fix all of them.
Comment 10 errata-xmlrpc 2015-02-19 10:39:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0240.html

Note You need to log in before you can comment on or make changes to this bug.