Bug 71210 - upgrade of kernel from 2.4.18-3 to 2.4.18-5 causes boot problems
Summary: upgrade of kernel from 2.4.18-3 to 2.4.18-5 causes boot problems
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-09 23:46 UTC by David C. Carroll
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 00:33:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David C. Carroll 2002-08-09 23:46:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
HP Laptop Pavilion N5470

after up2date from -3 to -5.  This upgrade was performed three times from scratch.
boot sequence hangs at varies steps. reboot brings sequence to next error until
finally logon occurs.  Errors include hda seek, USB filesystem/controller
errors, reconfigure ESS sound, etc.  After logon system will run but hangs on
various functions like find in file.  Sometime total lockup which requires hard
reset.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.3 from bought CD's from redhat.  Install works. (2.4.18-3)
2. run up2date for kernel which loads 2.4.18-5. No errors on install.
3. reboot.
	

Actual Results:  Multiple errors on reboot.

Expected Results:  no errors as with CD install

Additional info:

AMD 1.0 Ghz processor.
20G HD Hitachi DK23BA-20-19077 MB

example hda error:
  dma-intr:status=0x51{driveready seekcomplete error hda: dma_intr:
error=0x40{uncorrectable error}
  LBAsect=5081255,sector 4984864 end-request: I/O error, dev 03:02(hda), sector
4984864

Comment 1 David C. Carroll 2002-08-12 00:48:11 UTC
update info:

I found that it also occurs on -3.  Turns out that leaving laptop off for 
extended period time (3-4 hrs; overnight) creates problem.  After getting 
login, a cold restart or a warm restart works ok except for always finding new 
sound hardware.  It appears mainly to be a hd access problem.


Comment 2 Arjan van de Ven 2002-08-14 12:17:29 UTC
uncorrectable error} usually means "your disk is dying"....
can you try to run the smartctl program from the kernel-utils package to do a
disk health check ?

Comment 3 Arjan van de Ven 2002-08-14 12:18:08 UTC
uncorrectable error} usually means "your disk is dying"....
can you try to run the smartctl program from the kernel-utils package to do a
disk health check ?

Comment 4 David C. Carroll 2002-08-15 00:33:10 UTC
Yes I will try to run smartctl program.

I don't believe it to be a hard drive since the laptop is 1 yr. old (I know 
they can die early) and it was running the -3 version just fine.  I will re-
install the -3 vers. from scratch since I can't use it right now with -5 and 
try the program.

I will let you know the results.

Comment 5 David C. Carroll 2002-08-18 20:36:26 UTC
I ran smartctl and it resulted in input/output errors on both short and 
extended tests.  I ran it on -3.  This was after a period of use > 15 minutes.  
It looks like the hd is defective.  This will be a battle with the warranty 
people.

Thanks for your help.
Dave Carroll


Note You need to log in before you can comment on or make changes to this bug.