Bug 712310 - [Advance Search]Search plan via product and version the result is not accurately
[Advance Search]Search plan via product and version the result is not accurately
Status: CLOSED DEFERRED
Product: TCMS
Classification: Other
Component: Application (Show other bugs)
3.4.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Yuguang Wang
tools-bugs
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-10 05:25 EDT by Jin Zhao
Modified: 2012-08-06 04:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-26 01:34:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jin Zhao 2011-06-10 05:25:33 EDT
Description of problem:
Search plan via product and version the result contain other plan with unselected version

Version-Release number of selected component (if applicable):
3.4.1-2

How reproducible:
100%

Steps to Reproduce:
1.In advance search  https://tcms.englab.nay.redhat.com/advance-search/
2.Select product"TCMS" and version "3.4-1" in plan field
3.Click Search Plan
4.Click case 2797 to verify the plan version. https://tcms.englab.nay.redhat.com/plan/2797/
  
Actual results:
The version of plan2797 is "1.0" rather than "3.4-1"

Expected results:
Will list all the plan's version are 3.4-1

Additional info:
Comment 1 Danqing Li 2011-07-08 05:40:16 EDT
Dev found this issue relate with the database .

Test plan has no product_version field, when search the test plan by test plan version , all the plan's version before the set one will be in result.

The database is under improvement, so move this bug into next version.
Comment 2 Danqing Li 2011-12-26 01:34:08 EST
Deferred to 4.0
Comment 3 Xin Gao 2012-08-06 02:17:34 EDT

*** This bug has been marked as a duplicate of bug 844883 ***

Note You need to log in before you can comment on or make changes to this bug.