Bug 71232 - up2date error after launch
up2date error after launch
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-08-10 14:11 EDT by Joachim Kunze
Modified: 2015-01-07 18:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-12 17:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Joachim Kunze 2002-08-10 14:11:32 EDT
Description of Problem:
after launching up2date I receive the following error-message:

Error Message:
    Please run rhn_register as root on this client
Error Class Code: 9
Error Class Info: Invalid Server Certificate.
     An error has occurred while processing your request. If this problem
     persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

Bu I coa't run rhn_register simply because it is not available

Version-Release number of selected component (if applicable):
Comment 1 Joachim Kunze 2002-08-11 08:26:23 EDT
After deleting /etc/sysconfig/rhn/systemid, up2date was lauched, but I received
the following messaage, when up2date tried to create the list of installted rpms:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 692, in onRegPackagePagePrepare
    packages = rpmUtils.getInstalledPackageList(progressCallbac = pwin.setProgress)
NameError: global name 'rpmUtils' is not defined
Comment 2 Michael Young 2002-08-11 14:31:14 EDT
Note you need rpm packages (especially rpm-python) version 4.1-0.75 with this
version of up2date, 4.1-0.69 definitely doesn't work.
Comment 3 Joachim Kunze 2002-08-11 14:42:17 EDT
rpm-python-4.1-0.75 is what I'm currently using
Comment 4 Adrian Likins 2002-08-12 17:47:53 EDT
missing import, fixed in 2.9.40 (along with many other gui bugs)
Comment 5 Jay Turner 2002-08-16 09:05:16 EDT
Fix confirmed with up2date-2.9.46-1.

Note You need to log in before you can comment on or make changes to this bug.