Bug 712359 - Error messages displayed incorrectly in locales where the translation is missing
Error messages displayed incorrectly in locales where the translation is missing
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.7
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: James Antill
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-10 08:34 EDT by Ondrej Hudlicky
Modified: 2014-01-21 01:23 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 17:25:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Hudlicky 2011-06-10 08:34:38 EDT
Description of problem:
Error messages displayed incorrectly in locales where the translation is missing = all except following list: $ rpm -ql yum | grep locale
Tested cs_CZ.UTF-8 ja_JP.UTF-8 (bug) de_DE.UTF-8 (localized, displays correctly)

Version-Release number of selected component (if applicable):
yum-3.2.22-35.el5

How reproducible:
always

Steps to Reproduce:
1. setup e.g. incorrect yum repo
2. $ export LANG=cs_CZ.UTF-8
3. invoke error message: $ yum search foo
  
Actual results:
$ LANG=cs_CZ.UTF-8 yum search foo
repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Nezn\xc3\xa1m\xc3\xa9 jm\xc3\xa9no nebo slu\xc5\xbeba')>
Trying other mirror.

$ LANG=ja_JP.UTF-8 yum search foo
repomd.xml: [Errno 4] IOError: <urlopen error (-2, '\xe5\x90\x8d\xe5\x89\x8d\xe3\x81\xbe\xe3\x81\x9f\xe3\x81\xaf\xe3\x82\xb5\xe3\x83\xbc\xe3\x83\x93\xe3\x82\xb9\xe3\x81\x8c\xe4\xb8\x8d\xe6\x98\x8e\xe3\x81\xa7\xe3\x81\x99')>

Expected results:
Error message for these locales displayed correctly in English:
repomd.xml: [Errno 4] IOError: <urlopen error (-2, 'Name or service not known')>

Additional info:
Comment 1 James Antill 2011-08-25 17:11:31 EDT
 This sucks, but it's probably a bad idea to try and fix it at this point in RHEL-5 ... esp. as we ignore the LANG anyway in RHEL/yum. I guess we could override the LANG environment to always be en_US.utf-8.

 The problem with fixing it is that it introduced more bugs upstream, due to the bad way python handles unicode, and backporting all the fixes will be hard and prone to error (mainly of missing some).

 There is an unsupported "RHEL-6 and rawhide rebuild" repo. for RHEL-5 (and Fedora's) on repos.fedorapeople.org ... so a customer can try that. Or move to RHEL-6 :).
Comment 2 RHEL Product and Program Management 2011-08-25 17:25:24 EDT
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.