Bug 71266 - samba make crashed
samba make crashed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-11 12:34 EDT by Roberto Re
Modified: 2007-04-18 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-02 20:37:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roberto Re 2002-08-11 12:34:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
[root@fuoco source]# make
Using FLAGS =  -O  -O2 -march=i386 -mcpu=i686  -Iinclude -I./include -
I./ubiqx -I./smbwrapper -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -
D_GNU_SOURCE  -DLOGFILEBASE="/usr/local/samba/var" -
DCONFIGFILE="/usr/local/samba/lib/smb.conf" -
DLMHOSTSFILE="/usr/local/samba/lib/lmhosts"   -
DSWATDIR="/usr/local/samba/swat" -DSBINDIR="/usr/local/samba/bin" -
DLOCKDIR="/usr/local/samba/var/locks" -
DCODEPAGEDIR="/usr/local/samba/lib/codepages" -
DDRIVERFILE="/usr/local/samba/lib/printers.def" -
DBINDIR="/usr/local/samba/bin" -DPIDDIR="/usr/local/samba/var/locks" -
DLIBDIR="/usr/local/samba/lib" -DHAVE_INCLUDES_H -
DPASSWD_PROGRAM="/usr/bin/passwd"
-DSMB_PASSWD_FILE="/usr/local/samba/private/smbpasswd" -
DTDB_PASSWD_FILE="/usr/local/samba/private/smbpasswd.tdb"
Using FLAGS32 =  -O  -O2 -march=i386 -mcpu=i686  -Iinclude -I./include -
I./ubiqx
 -I./smbwrapper -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  -
DLOGFILEBASE="/usr/local/samba/var" -
DCONFIGFILE="/usr/local/samba/lib/smb.conf" -
DLMHOSTSFILE="/usr/local/samba/lib/lmhosts"   -
DSWATDIR="/usr/local/samba/swat" -DSBINDIR="/usr/local/samba/bin" -
DLOCKDIR="/usr/local/samba/var/locks" -
DCODEPAGEDIR="/usr/local/samba/lib/codepages" -
DDRIVERFILE="/usr/local/samba/lib/printers.def" -
DBINDIR="/usr/local/samba/bin" -DPIDDIR="/usr/local/samba/var/locks" -
DLIBDIR="/usr/local/samba/lib" -DHAVE_INCLUDES_H -
DPASSWD_PROGRAM="/usr/bin/passwd" -
DSMB_PASSWD_FILE="/usr/local/samba/private/smbpasswd" -
DTDB_PASSWD_FILE="/usr/local/samba/private/smbpasswd.tdb"
Using LIBS = -lcups -lssl -lcrypto -lnsl -lcrypt -lpam -lpopt
Compiling rpc_server/srv_spoolss.c
In file included from include/includes.h:77,
                 from rpc_server/srv_spoolss.c:25:
/usr/include/sys/time.h:58: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [rpc_server/srv_spoolss.o] Error 1
[root@fuoco source]# make
Using FLAGS =  -O  -O2 -march=i386 -mcpu=i686  -Iinclude -I./include -
I./ubiqx -I./smbwrapper -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -
D_GNU_SOURCE  -DLOGFILEBASE="/usr/local/samba/var" -
DCONFIGFILE="/usr/local/samba/lib/smb.conf" -
DLMHOSTSFILE="/usr/local/samba/lib/lmhosts"   -
DSWATDIR="/usr/local/samba/swat" -DSBINDIR="/usr/local/samba/bin" -
DLOCKDIR="/usr/local/samba/var/locks" -
DCODEPAGEDIR="/usr/local/samba/lib/codepages" -
DDRIVERFILE="/usr/local/samba/lib/printers.def" -
DBINDIR="/usr/local/samba/bin" -DPIDDIR="/usr/local/samba/var/locks" -
DLIBDIR="/usr/local/samba/lib" -DHAVE_INCLUDES_H -
DPASSWD_PROGRAM="/usr/bin/passwd"
-DSMB_PASSWD_FILE="/usr/local/samba/private/smbpasswd" -
DTDB_PASSWD_FILE="/usr/local/samba/private/smbpasswd.tdb"
Using FLAGS32 =  -O  -O2 -march=i386 -mcpu=i686  -Iinclude -I./include -
I./ubiqx
 -I./smbwrapper -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE  -
DLOGFILEBASE="/usr/local/samba/var" -
DCONFIGFILE="/usr/local/samba/lib/smb.conf" -
DLMHOSTSFILE="/usr/local/samba/lib/lmhosts"   -
DSWATDIR="/usr/local/samba/swat" -DSBINDIR="/usr/local/samba/bin" -
DLOCKDIR="/usr/local/samba/var/locks" -
DCODEPAGEDIR="/usr/local/samba/lib/codepages" -
DDRIVERFILE="/usr/local/samba/lib/printers.def" -
DBINDIR="/usr/local/samba/bin" -DPIDDIR="/usr/local/samba/var/locks" -
DLIBDIR="/usr/local/samba/lib" -DHAVE_INCLUDES_H -
DPASSWD_PROGRAM="/usr/bin/passwd" -
DSMB_PASSWD_FILE="/usr/local/samba/private/smbpasswd" -
DTDB_PASSWD_FILE="/usr/local/samba/private/smbpasswd.tdb"
Using LIBS = -lcups -lssl -lcrypto -lnsl -lcrypt -lpam -lpopt
Compiling rpc_server/srv_spoolss.c
In file included from /usr/include/bits/types.h:143,
                 from /usr/include/sys/types.h:30,
                 from include/includes.h:74,
                 from rpc_server/srv_spoolss.c:25:
/usr/include/bits/pthreadtypes.h:89: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [rpc_server/srv_spoolss.o] Error 1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ./configure
2. ./make
3.
	

Additional info:

it's appened after a system up2date
Comment 1 Richard Henderson 2004-10-02 20:37:12 EDT
Samba has built since then.

Note You need to log in before you can comment on or make changes to this bug.