Bug 71280 - shadow-utils cannot be built with rpm-build-4.1-0.69 in limbo
Summary: shadow-utils cannot be built with rpm-build-4.1-0.69 in limbo
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-11 21:24 UTC by Daniel Resare
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-14 05:44:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Resare 2002-08-11 21:24:32 UTC
Description of Problem:

When I try to rebuild the shadow-utils package as distributed in limbo, I get
the following error:

    Installed (but unpackaged) file(s) found:
   /bin/login
   /bin/su
   /lib/libshadow.a
   /lib/libshadow.la
   /usr/bin/chfn
   /usr/bin/chsh
   ....

This seems to be due to a behaviour change in rpm that should be compensated for.

Versions:

shadow-utils-20000902-10.src.rpm
rpm-build-4.1-0.69

Comment 1 Bill Nottingham 2002-08-14 05:44:28 UTC
Do you have redhat-rpm-config installed?

Comment 2 Nalin Dahyabhai 2002-08-14 06:24:04 UTC
This is not a bug.  RHL ships with the util-linux versions of chfn, chsh, and
login, and the shellutils version of su.  If this is preventing binary packages
from being generated (it doesn't on my system -- a binary package is produced),
then please reopen this bug, otherwise it's an expected warning.

Comment 3 Daniel Resare 2002-08-15 09:39:46 UTC
Installing redhat-rpm-config does the difference changes the error into a
warning and packages gets built anyway.

I believe this will bite many people, perhaps making rpm-build require
redhat-rpm-config would be a good idea?


Note You need to log in before you can comment on or make changes to this bug.