Bug 71281 - bug in sv.po disables non-ascii chars in localized output
bug in sv.po disables non-ascii chars in localized output
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: shadow-utils (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-11 17:26 EDT by Daniel Resare
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-29 17:18:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch fixes the problem for me (398 bytes, patch)
2002-08-15 05:34 EDT, Daniel Resare
no flags Details | Diff

  None (edit)
Description Daniel Resare 2002-08-11 17:26:24 EDT
Description of Problem:

The localized messages from for example /usr/sbin/useradd comes out with invalid
utf-8 sequences for all non-ascii characters. For example 

[noa@ulysses BUILD]$ /usr/sbin/useradd 
Anv�ndning: useradd     [-u uid [-o]] [-g grupp] [-G grupp,...] 
...

when it should instead say

"Anvdndning: useradd ..."

I believe this problem is related to the fact that the first message of sv.po is
marked as fuzzy, and therefore the gettext system doesn't get the information
that the incoming data is encoded in iso-8859-1, and assumes us-ascii or
something like it. Removing the fuzzy marking should fix the problem I believe. 

However I cannot test it since #71280 is blocking me

Version-Release number of selected component (if applicable):
shadow-utils-20000902-10
Comment 1 Daniel Resare 2002-08-15 05:34:14 EDT
Created attachment 70804 [details]
this patch fixes the problem for me
Comment 2 Nalin Dahyabhai 2002-08-29 17:18:34 EDT
Fixing for shadow-utils-20000902-12.  Thanks!
Comment 3 Jay Turner 2002-09-04 00:02:47 EDT
Fix confirmed with shadow-utils-20000902-12.

Note You need to log in before you can comment on or make changes to this bug.