Bug 71301 - TAB in file selector clears entry
TAB in file selector clears entry
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: libgnomeui (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: FutureFeature, MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-12 05:19 EDT by Kjetil T. Homme
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-12 22:56:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2002-08-12 05:19:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020808

Description of problem:
if you enter a filename which can't be expanded uniquely and press TAB, the
characters you have typed will be removed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. fire up a file selector
2. enter /u TAB X TAB lib TAB

	

Actual Results:  hopefully, you should now have navigated into /usr/X11R6. the
left selector box contains . .. lib libexec, your text entry widget is cleared
("/usr/X11R6/").

Expected Results:  as above, except the text entry widget should still contain
"/usr/X11R6/lib".


Additional info:

the testing was done with gtk2-2.0.6-1
Comment 1 Owen Taylor 2002-08-12 11:40:38 EDT
I can't reproduce. What app are you testing in?

Comment 2 Kjetil T. Homme 2002-08-12 11:53:42 EDT
I used gdmsetup from gdm-2.4.0.7-1
Comment 3 Owen Taylor 2002-10-31 19:28:17 EST
Looks like a GnomePixmapEntry bug - I can reproduce it with
libgnomeui/test-gnome.
Comment 4 Havoc Pennington 2003-01-12 22:56:46 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103313

Note You need to log in before you can comment on or make changes to this bug.