Bug 71319 - balsa requires libesmtp later than 0.8.4
balsa requires libesmtp later than 0.8.4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: balsa (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-12 06:41 EDT by Göran Uddeborg
Modified: 2014-03-16 22:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.0.11-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 14:33:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2002-08-12 06:41:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
balsa fails to start with an libesmtp from Red Hat 7 series, although all RPM
dependencies are met.

Version-Release number of selected component (if applicable): 0.8.12-2


How reproducible:
Always

Steps to Reproduce:
1.Install libesmtp-0.8.4-2
2.Install balsa from the beta
3.Run balsa


Actual Results:
uebn> balsa
balsa: relocation error: balsa: undefined symbol: smtp_starttls_set_password_cb


Expected Results:  I would have expected a balsa window.

Additional info:

The balsa binary itself references the symbol smtp_starttls_set_password_cb. 
This is defined in the library libesmtp.so.5.0.12 from libesmtp-0.4.12-2.

But the balsa RPM only requires libesmtp.so.5.  That is also provided by the
older libesmtp 0.8.4-2 from Red Hat 7.3 (and 7.2).  This particlular symbol is
not available in that version of the library.  So the loading fails.

I haven't researched exactly in which version of libesmtp the symbol appeared. 
But I obviously a "Requires libesmtp >= 0.4.12" would be on the safe side, and
cover any libesmtp versions released by Red Hat in a correct way.
Comment 1 Bill Nottingham 2002-11-05 15:37:59 EST
Will be fixed in the next build (which will be a new version anyway.)
Comment 2 Göran Uddeborg 2003-10-03 13:32:08 EDT
This does not at all seem fixed.  It is quite possible to install balsa-2.0.11-2
and libesmtp-0.8.4-2 together without any complaints from RPM.  And it still
fails when running the same way.

Doing "rpm -q --requires balsa" only mentions libesmtp.so.5 just as before, and
that apparently is not fine-grained enough.
Comment 3 Bill Nottingham 2003-10-03 14:33:29 EDT
Woops, it was added as a BuildRequire.

Note You need to log in before you can comment on or make changes to this bug.