Bug 713613 - Unable to install ntop on F15 i686
Summary: Unable to install ntop on F15 i686
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ntop
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-06-15 23:06 UTC by Marco Hartgring
Modified: 2011-12-04 02:27 UTC (History)
10 users (show)

Fixed In Version: ntop-3.4-0.6.pre3.fc15.1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-04 02:22:12 UTC


Attachments (Terms of Use)

Description Marco Hartgring 2011-06-15 23:06:15 UTC
Description of problem:
Unable to install ntop on F15 i686

Version-Release number of selected component (if applicable):
ntop-3.4-0.5.pre3.fc15.i686

How reproducible:
Always

Steps to Reproduce:
1. yum install ntop
  
Actual results:
Loaded plugins: etckeeper, presto, refresh-packagekit, remove-with-leaves
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ntop.i686 0:3.4-0.5.pre3.fc15 will be installed
--> Processing Dependency: graphviz for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 453b804e83a8a45a07a3a4b2b7e3d453ce9a70.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 26f28e7a5d17bf3e13397105d19786767ef3b2.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: d6023a2ea5b64acf2e0dbd895d1321e6199cbb.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ad1eb47bbdeebc1dde3036c9a7626df0393a9b.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 92ea8a23638aabc035a224e2320a2612a0ed73.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 51fa32419268a4e8c274a302fc392f772c1049.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ce2c2471c1799491c6bd24d45019188bcb65b5.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Running transaction check
---> Package graphviz.i686 0:2.26.3-4.fc15 will be installed
--> Processing Dependency: libXaw.so.7 for package: graphviz-2.26.3-4.fc15.i686
--> Processing Dependency: libXmu.so.6 for package: graphviz-2.26.3-4.fc15.i686
--> Processing Dependency: libXt.so.6 for package: graphviz-2.26.3-4.fc15.i686
---> Package ntop.i686 0:3.4-0.5.pre3.fc15 will be installed
--> Processing Dependency: 453b804e83a8a45a07a3a4b2b7e3d453ce9a70.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 26f28e7a5d17bf3e13397105d19786767ef3b2.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: d6023a2ea5b64acf2e0dbd895d1321e6199cbb.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ad1eb47bbdeebc1dde3036c9a7626df0393a9b.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 92ea8a23638aabc035a224e2320a2612a0ed73.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 51fa32419268a4e8c274a302fc392f772c1049.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ce2c2471c1799491c6bd24d45019188bcb65b5.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Running transaction check
---> Package libXaw.i686 0:1.0.8-1.fc15 will be installed
---> Package libXmu.i686 0:1.1.0-2.fc15 will be installed
---> Package libXt.i686 0:1.1.0-1.fc15 will be installed
---> Package ntop.i686 0:3.4-0.5.pre3.fc15 will be installed
--> Processing Dependency: 453b804e83a8a45a07a3a4b2b7e3d453ce9a70.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 26f28e7a5d17bf3e13397105d19786767ef3b2.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: d6023a2ea5b64acf2e0dbd895d1321e6199cbb.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ad1eb47bbdeebc1dde3036c9a7626df0393a9b.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 92ea8a23638aabc035a224e2320a2612a0ed73.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: 51fa32419268a4e8c274a302fc392f772c1049.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Processing Dependency: ce2c2471c1799491c6bd24d45019188bcb65b5.debug for package: ntop-3.4-0.5.pre3.fc15.i686
--> Finished Dependency Resolution
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: d6023a2ea5b64acf2e0dbd895d1321e6199cbb.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: 51fa32419268a4e8c274a302fc392f772c1049.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: 453b804e83a8a45a07a3a4b2b7e3d453ce9a70.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: ad1eb47bbdeebc1dde3036c9a7626df0393a9b.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: 26f28e7a5d17bf3e13397105d19786767ef3b2.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: 92ea8a23638aabc035a224e2320a2612a0ed73.debug
Error: Package: ntop-3.4-0.5.pre3.fc15.i686 (fedora)
           Requires: ce2c2471c1799491c6bd24d45019188bcb65b5.debug
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
An installed package

Additional info:
rpm -qp --requires ntop-3.4-0.5.pre3.fc15.i686.rpm | grep debug
26f28e7a5d17bf3e13397105d19786767ef3b2.debug  
453b804e83a8a45a07a3a4b2b7e3d453ce9a70.debug  
51fa32419268a4e8c274a302fc392f772c1049.debug  
92ea8a23638aabc035a224e2320a2612a0ed73.debug  
ad1eb47bbdeebc1dde3036c9a7626df0393a9b.debug  
ce2c2471c1799491c6bd24d45019188bcb65b5.debug  
d6023a2ea5b64acf2e0dbd895d1321e6199cbb.debug

Comment 1 Rakesh Pandit 2011-06-24 15:41:50 UTC
I will have a look in couple of days. Thanks for reporting.

Comment 2 Petros Athanassopoulos 2011-06-26 16:18:19 UTC
(In reply to comment #1)
> I will have a look in couple of days. Thanks for reporting.

Dear Rakesh,

when you do take a look please also check the following option in /etc/ntop.conf since a) it is enabled by default but b) it is not supported in neither x86_64 nor i686 (which I installed manually, the dependencies with yum and the problematic rpm with rpm -i --nodeps ntop-3.4-0.5.pre3.fc15.i686.rpm)

***QUOTE***
# Under certain circumstances, the sched_yield() function causes the ntop web 
# server to lock up.  It shouldn't happen, but it does.  This option causes 
# ntop to skip those calls, at a tiny performance penalty.
--disable-schedyield
***UNQUOTE***

Comment 3 ts 2011-11-05 18:08:51 UTC
Hi,

whats the status of this bug?

TIA

Thomas

Comment 4 Gregory Sloop 2011-11-08 00:14:59 UTC
Not to beat a dead horse, but really...
Nov 7 is MORE than a few days after June 24.
Does someone plan to address this?


Even better than fixing 3.4 would be a new build on NTop 4.1 [It's been out quite a while.]

Thanks,
Greg

Comment 5 Andre Robatino 2011-11-08 00:27:11 UTC
It IS installable on F16 i686, at least (as well as F16 x86_64):

[root@dell-pc ~]# yum install ntop
Loaded plugins: langpacks, presto, refresh-packagekit, security
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ntop.i686 0:3.4-0.9.pre3.fc16 will be installed
--> Processing Dependency: graphviz for package: ntop-3.4-0.9.pre3.fc16.i686
--> Processing Dependency: librrd_th.so.4 for package: ntop-3.4-0.9.pre3.fc16.i686
--> Running transaction check
---> Package graphviz.i686 0:2.28.0-9.fc16 will be installed
--> Processing Dependency: libgvplugin_gd.so.6 for package: graphviz-2.28.0-9.fc16.i686
---> Package rrdtool.i686 0:1.4.4-6.fc16 will be installed
--> Processing Dependency: dejavu-lgc-sans-mono-fonts for package: rrdtool-1.4.4-6.fc16.i686
--> Running transaction check
---> Package dejavu-lgc-sans-mono-fonts.noarch 0:2.33-1.fc16 will be installed
---> Package graphviz-gd.i686 0:2.28.0-9.fc16 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                       Arch      Version                Repository
                                                                           Size
================================================================================
Installing:
 ntop                          i686      3.4-0.9.pre3.fc16      fedora     17 M
Installing for dependencies:
 dejavu-lgc-sans-mono-fonts    noarch    2.33-1.fc16            fedora    358 k
 graphviz                      i686      2.28.0-9.fc16          fedora    1.1 M
 graphviz-gd                   i686      2.28.0-9.fc16          fedora     26 k
 rrdtool                       i686      1.4.4-6.fc16           fedora    348 k

Transaction Summary
================================================================================
Install       5 Packages

Total download size: 18 M
Installed size: 18 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): dejavu-lgc-sans-mono-fonts-2.33-1.fc16.noarch.rpm | 358 kB     00:01     
(2/5): graphviz-2.28.0-9.fc16.i686.rpm                   | 1.1 MB     00:03     
(3/5): graphviz-gd-2.28.0-9.fc16.i686.rpm                |  26 kB     00:00     
(4/5): ntop-3.4-0.9.pre3.fc16.i686.rpm                   |  17 MB     01:09     
(5/5): rrdtool-1.4.4-6.fc16.i686.rpm                     | 348 kB     00:01     
--------------------------------------------------------------------------------
Total                                           245 kB/s |  18 MB     01:16     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : dejavu-lgc-sans-mono-fonts-2.33-1.fc16.noarch                1/5 
  Installing : rrdtool-1.4.4-6.fc16.i686                                    2/5 
  Installing : graphviz-2.28.0-9.fc16.i686                                  3/5 
  Installing : graphviz-gd-2.28.0-9.fc16.i686                               4/5 
  Installing : ntop-3.4-0.9.pre3.fc16.i686                                  5/5 

Installed:
  ntop.i686 0:3.4-0.9.pre3.fc16                                                 

Dependency Installed:
  dejavu-lgc-sans-mono-fonts.noarch 0:2.33-1.fc16 graphviz.i686 0:2.28.0-9.fc16
  graphviz-gd.i686 0:2.28.0-9.fc16                rrdtool.i686 0:1.4.4-6.fc16  

Complete!
[root@dell-pc ~]#

Comment 6 Rakesh Pandit 2011-11-08 04:24:41 UTC
(In reply to comment #4)
> Not to beat a dead horse, but really...
> Nov 7 is MORE than a few days after June 24.
> Does someone plan to address this?
> 
> 
> Even better than fixing 3.4 would be a new build on NTop 4.1 [It's been out
> quite a while.]
> 
> Thanks,
> Greg

I will have a look this weekend.

Comment 7 Marco Hartgring 2011-11-24 06:50:06 UTC
Another two weeks have passed and no update...

Comment 8 Rakesh Pandit 2011-11-24 07:01:29 UTC
(In reply to comment #7)
> Another two weeks have passed and no update...

I am really sorry. Have been very busy with my day job. I will update in a day or ping a proven packager to help me here in case I cannot handle it till tomorrow.

Comment 9 Mamoru TASAKA 2011-11-24 10:07:35 UTC
Please don't use '%{_libdir}/*' in %files in the spec file.

Debuginfo files are installed under %_buildroot/%{_libdir} and if you write %{_libdir}/* in the spec file, the rebuilt binary rpm will contain debuginfo-related files in non-debuginfo binary rpm, see:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=2475998

and this may cause unexpected results like this.

You should write
%{_libdir}/lib%{name}-*.so
%{_libdir}/%{name}/
in %files in the spec file, not using %{_libdir}/*

Comment 11 Sven Lankes 2011-11-24 11:37:31 UTC
I'm working on this issue now.

A kind reminder for everyone in the future: Please don't pile up issues in one bug. One bug per issue makes it much easier not to overlook issues.

Comment 12 Rakesh Pandit 2011-11-24 11:57:03 UTC
(In reply to comment #10)
> By the way I see this commit
> 
> http://pkgs.fedoraproject.org/gitweb/?p=ntop.git;a=commitdiff;h=9cf60d0f0589883e9f8cd47cfff1c62844bf718c

Thank you Mamoru :)

Yes, earlier most of work was done by my co-maintainer and I haven't been updated with changes since long now. :-/

Will push an update for F15. Sven Lankes will possibly have a look at 4.1 update.

Regards,

Comment 13 Fedora Update System 2011-11-24 12:29:41 UTC
ntop-4.1.0-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ntop-4.1.0-1.fc16

Comment 14 Fedora Update System 2011-11-24 13:33:41 UTC
ntop-3.4-0.6.pre3.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ntop-3.4-0.6.pre3.fc15.1

Comment 15 Fedora Update System 2011-11-25 01:59:07 UTC
Package ntop-3.4-0.6.pre3.fc15.1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ntop-3.4-0.6.pre3.fc15.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16352/ntop-3.4-0.6.pre3.fc15.1
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2011-12-04 02:22:12 UTC
ntop-4.1.0-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2011-12-04 02:27:50 UTC
ntop-3.4-0.6.pre3.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.