Bug 71366 - [patch]: tell the user when bind didn't restart and why
[patch]: tell the user when bind didn't restart and why
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-12 14:40 EDT by Marc MERLIN
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 11:24:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tell the user when bind didn't restart correctly, and why (3.34 KB, patch)
2002-08-12 14:43 EDT, Marc MERLIN
no flags Details | Diff

  None (edit)
Description Marc MERLIN 2002-08-12 14:40:54 EDT
Bind sucks at saying when it failed to start or if it failed to load a zone
I wrote code a while ago to fix that by reading the logs it generates and
showing errors to the admin

I recently ported my code from debian to Red Hat's initscript since I can't 
live without it.
Basically, here's what you get:

deeptought:/etc/init.d# /etc/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named: Waiting for test name server to be ready...........
Aug 12 10:55:35.659 network: info: no longer listening on 10.31.1.2#53
Aug 12 10:55:35.659 network: info: no longer listening on 10.31.1.3#53
Aug 12 10:55:35.659 network: info: no longer listening on 10.7.0.2#53
Aug 12 10:55:35.659 network: info: no longer listening on 10.7.0.3#53
Aug 12 10:55:35.808 general: notice: exiting
Aug 12 10:55:36 deeptought named[13453]: /etc/named.conf:54: unknown option 'zone'
Aug 12 10:55:36 deeptought named[13453]: /etc/named.conf:59: unknown option 'zone'
Aug 12 10:55:36 deeptought named[13453]: /etc/named.conf:64: open:
../zone.master: file not found
Aug 12 10:55:36 deeptought named[13453]: loading configuration: file not found
Aug 12 10:55:36 deeptought named[13453]: exiting (due to fatal error)
Name server failed to start successfully, you need to check this by hand
deeptought:/etc/init.d# /etc/init.d/named restart
Stopping named:                                            [FAILED]
Starting named: Waiting for test name server to be ready.. done
Checking server logs for errors and warnings...
Aug 12 10:56:24.515 general: error: dns_rdata_fromtext:
engr.intransa.com/engr.intransa.com:13: near 'IN': extra input text
Aug 12 10:56:24.516 general: error: zone engr.intransa.com/IN: loading master
file engr.intransa.com/engr.intransa.com: extra input text
done
Find out where the error is from
deeptought:/etc/init.d# /etc/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named: Waiting for test name server to be ready.. done
Checking server logs for errors and warnings...
done
                                                           [  OK  ]

The patch probably has a couple of rough edges wrt the integration with the
start/stop OK/FAILED system, but the output works.
It also depends on NAMEDCHECKSTARTLOGFILE, which is set to no by default, and
needs to be enabled in /etc/sysconfig/named before my code quicks in
Comment 1 Marc MERLIN 2002-08-12 14:43:50 EDT
Created attachment 70104 [details]
Tell the user when bind didn't restart correctly, and why
Comment 2 Daniel Walsh 2003-01-07 11:24:34 EST
We are attempting to speed up boot process, so a patch like this would not be
accepted.  We are looking to add a message bus, which an application like bind
could call when it fails to start.  The user could then be informed.

Thanks,

Dan

Note You need to log in before you can comment on or make changes to this bug.