Bug 713669 - Using the indexterm tag causes a line split in rendered PDF files.
Using the indexterm tag causes a line split in rendered PDF files.
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-16 03:46 EDT by Norman Dunbar
Modified: 2011-07-25 20:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-25 20:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Norman Dunbar 2011-06-16 03:46:20 EDT
Description of problem:
In a document where the <indexterm> tag is used, all generated PDF files have a line split after the indexed term. See "Steps to Reproduce" below. This does not occur in generated HTML.


Version-Release number of selected component (if applicable):
Publican 2.1 - on Scientific Linux 6.0 (RHEL 6.0)
Publican 2.3 - on Windows 2000 & XP.
Publican 2.5 on Fedora 14.


How reproducible:
100%


Steps to Reproduce:
1. Create a new book.
2. Enter the following in one of the chapters:

<para>Blah blah blah publican<indexterm><primary>Publican</primary></indexterm> blah blah blah...</para>

3. Build pdf document.

  
Actual results:

The generated xsl/fo is:

<fo:block ...>
    Blah blah blah publican
    <fo:block ...>
        <fo:wrapper id="id3189566">
            <!--Publican-->
        </fo:wrapper>       
    </fo:block>
    blah blah blah...
</fo:block>


And the text in the PDF looks like this:

Blah blah blah publican
blah blah blah...


Expected results:

Blah blah blah publican blah blah blah...



Additional info:
There appears to be an <fo:block> wrapped around the <fo:wrapper>, this causes the linefeed after the indexed term. This is caused in pdf.xsl in which there is a template commented as being copied in from index.xsl from Docbook XSL version 1.72. The template name is "indexterm".

This template has the <fo:block> stuff added in two places which is not in Docbook XSL version 1.75 plus the test on $axf.extensions in Publican is different from that in Docbook which checks both $axf.extensions and $fop1.extensions.

If I comment out the two <fo:block> lines in pdf.xsl, it works as I wish, however, that may introduce other troubles elsewhere.
Comment 1 Jeff Fearn 2011-07-07 22:42:32 EDT
Fixed override to apply style change better. Applied to trunk and branches/publican-2x

Committed revision 1822.
Comment 2 Rebecca Newton 2011-07-12 01:51:27 EDT
Verified. The text appears as one line in a PDF when using <indexterm>.

Note You need to log in before you can comment on or make changes to this bug.