Bug 713684 - in system groups subtab on system details page hints are displayed as "?????..."
in system groups subtab on system details page hints are displayed as "?????..."
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: i18n (Show other bugs)
541
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomas Lestach
Martin Korbel
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2011-06-16 05:02 EDT by Jan Hutař
Modified: 2013-10-01 17:57 EDT (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-java-2.0.2-20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:57:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traditional Chinese (48.50 KB, image/png)
2011-06-16 05:02 EDT, Jan Hutař
no flags Details
Spanish (38.79 KB, image/png)
2011-06-16 05:02 EDT, Jan Hutař
no flags Details
Japanese (124.92 KB, image/png)
2013-09-25 05:29 EDT, Martin Korbel
no flags Details

  None (edit)
Description Jan Hutař 2011-06-16 05:02:08 EDT
Created attachment 505003 [details]
Traditional Chinese

Description of problem:
In all languages except English, we are getting incorrect display of hint messages. When in non-latin chars language, set of question marks appear, when in latin chars language (Francoise), only some of the chars are incorrect.


Version-Release number of selected component (if applicable):
spacewalk-java-1.2.39-85.el5sat


How reproducible:
always


Steps to Reproduce:
1. Set non-English locale
2. Go to Systems -> <some_system> -> Groups -> List / Leave and also try Join


Actual results:
See screenshots


Expected results:
List / Leave:
Below are all the system groups that have been added to this system. To remove a system group membership, check its checkbox and make sure you click the "Leave Selected Groups" button when you are finished with your changes. 
No System Groups. To add System Groups this system, please visit the Join tab.

Join:
Below is a list of system groups available to this system. To join a system group, check its checkbox. Make sure you click the "Join Selected Groups" button when you are finished with your changes.
Comment 1 Jan Hutař 2011-06-16 05:02:37 EDT
Created attachment 505004 [details]
Spanish
Comment 2 Jan Hutař 2011-06-16 05:22:17 EDT
I have checked on 5.4.0 and 5.3.0 (spacewalk-java-0.5.44-95.el5sat) and it is there as well.
Comment 3 Tomas Lestach 2011-06-16 13:01:01 EDT
It seems, we have more of such pages:
rhn/groups/AddSystems.do
rhn/groups/ListRemoveSystems.do
rhn/activationkeys/groups/Add.do
rhn/activationkeys/groups/List.do
and two already reported:
rhn/systems/details/groups/Add.do
rhn/systems/details/groups/ListRemove.do
Comment 5 Tomas Lestach 2012-09-11 10:10:26 EDT
Partial fix ...

spacewalk.git: 743f0d89d3f0406f8ac708c3aa9a51dcbc4dba2a
Comment 6 Tomas Lestach 2013-08-01 10:37:43 EDT
Taking ...
Comment 7 Tomas Lestach 2013-08-16 10:20:30 EDT
I am happy I finally finished this BZ.
I defined two new taglib functions, that localize the message parameters together with the message ...

spacewalk.git: 1fa61bb0face316e3dba7b43acc0bd50599e1009
Comment 10 Martin Korbel 2013-09-25 05:29:51 EDT
Created attachment 802665 [details]
Japanese

VERIFIED on spacewalk-java-2.0.2-39.el6sat (Satellite-5.6.0-RHEL6-re20130917.0)
REPRODUCED on spacewalk-java-1.2.39-29.el5sat (Satellite-5.4.0)
Comment 11 Clifford Perry 2013-10-01 17:57:25 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.