Bug 71385 - Strange: snmpd doesn't give any info about swap usage
Strange: snmpd doesn't give any info about swap usage
Status: CLOSED DUPLICATE of bug 67610
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-12 17:19 EDT by Dmitry S. Makovey
Modified: 2015-03-04 20:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 17:46:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitry S. Makovey 2002-08-12 17:19:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.0.0) Gecko/20020801

Description of problem:
When trying to obtain memory info from host snmpwalk/snmpget returns negative
values/zeros


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -i ucd-snmp-4.2.5-7.72.0.i386.rpm
2. configure /etc/hosts.allow + /etc/snmp/snmpd.conf to be able connect from
localhost
3. snmpwalk -c public -A passphrase localhost memory

Actual Results:  enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = -1
enterprises.ucdavis.memory.memAvailSwap.0 = -1
enterprises.ucdavis.memory.memTotalReal.0 = -1
enterprises.ucdavis.memory.memAvailReal.0 = -1
enterprises.ucdavis.memory.memTotalFree.0 = -2
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = -1
enterprises.ucdavis.memory.memBuffer.0 = -1
enterprises.ucdavis.memory.memCached.0 = -1
enterprises.ucdavis.memory.memSwapError.0 = 1
enterprises.ucdavis.memory.memSwapErrorMsg.0 = Running out of swap space (-1)


Expected Results:  enterprises.ucdavis.memory.memIndex.0 = 0
enterprises.ucdavis.memory.memErrorName.0 = swap
enterprises.ucdavis.memory.memTotalSwap.0 = <RealSwapSize>
enterprises.ucdavis.memory.memAvailSwap.0 = <AvailSwap>
enterprises.ucdavis.memory.memTotalReal.0 = <RealMem>
enterprises.ucdavis.memory.memAvailReal.0 = ...
enterprises.ucdavis.memory.memTotalFree.0 = ...
enterprises.ucdavis.memory.memMinimumSwap.0 = 16000
enterprises.ucdavis.memory.memShared.0 = ...
enterprises.ucdavis.memory.memBuffer.0 = ...
enterprises.ucdavis.memory.memCached.0 = ...
enterprises.ucdavis.memory.memSwapError.0 = 1
enterprises.ucdavis.memory.memSwapErrorMsg.0 = Running out of swap space (-1)


Additional info:

[root@host etc]# rpm -qa | grep ucd
ucd-snmp-4.2.5-7.72.0
ucd-snmp-utils-4.2.5-7.72.0
Comment 1 Dmitry S. Makovey 2002-08-12 17:46:54 EDT
just tried the same configuration on FreeBSD/net-snmp-5.0.3 - works.... 
dimon@host ~ > snmpwalk -c public localhost memory 
UCD-SNMP-MIB::memIndex.0 = INTEGER: 0 
UCD-SNMP-MIB::memErrorName.0 = STRING: swap 
UCD-SNMP-MIB::memTotalSwap.0 = INTEGER: 524160 
UCD-SNMP-MIB::memAvailSwap.0 = INTEGER: 493880 
UCD-SNMP-MIB::memTotalReal.0 = INTEGER: 209940 
UCD-SNMP-MIB::memAvailReal.0 = INTEGER: 5832 
UCD-SNMP-MIB::memTotalFree.0 = INTEGER: 41140 
UCD-SNMP-MIB::memMinimumSwap.0 = INTEGER: 16000 
UCD-SNMP-MIB::memShared.0 = INTEGER: 109876 
UCD-SNMP-MIB::memBuffer.0 = INTEGER: 35840 
UCD-SNMP-MIB::memCached.0 = INTEGER: 35308 
UCD-SNMP-MIB::memSwapError.0 = INTEGER: 0 
UCD-SNMP-MIB::memSwapErrorMsg.0 = STRING:  
 
I know it's a different version though but config file works ok for redhat 
linux except that memory problem...
Comment 2 Phil Knirsch 2002-08-13 03:23:35 EDT
This is due to a bug that was introduced in the upstream 4.2.5 version. It's
fixed in an upcoming errata which should go out in the next few weeks.

Read ya, Phil

*** This bug has been marked as a duplicate of 67610 ***

Note You need to log in before you can comment on or make changes to this bug.