This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71393 - ESD not enabled by default
ESD not enabled by default
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: libgnome (Show other bugs)
null
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-12 19:23 EDT by Warren Togami
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 12:16:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2002-08-12 19:23:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020804

Description of problem:
With both an upgrade from Red Hat 7.3 (old Gnome 1.4.x profile) and clean
install of Limbo2, ESD is not enabled by default.

If you go into Gnome Control Center > Sound you can check "Enable sound server
startup".  ESD then works fine.

Somewhat Related Bug 68205: Does ESD need "-d /dev/dsp" forced in /etc/esd.conf?
 I think not.

Note: Please do not enable "Sound for events" by default too.

Version-Release number of selected component (if applicable):
Limbo2 and Rawhide 8/12/2002

How reproducible:
Always

Steps to Reproduce:
1. Login to Gnome2 as an old user (Gnome 1.4.x) or new user.
2. Attempt to use ESD sound application.
	
Actual Results:  
ESD is not enabled by default, ESD sound applications play nothing.

Expected Results:  
ESD should be enabled by default.
Comment 1 Nathan G. Grennan 2002-08-13 00:32:54 EDT
Personally I would like to see this stay the way it is. esd has always done a
poor job of sound handling. The whole idea of esd/artsd is pretty backward. Is
much better to just get a card that accepts multiple wav inputs.
Comment 2 Mattias Dahlberg 2002-08-20 10:05:17 EDT
Well, it would be nice if XMMS worked out-of-the-box. I just tried Null and I 
had to put a checkmark in the Sound preferences box and reboot to get XMMS to 
play my MP3.
Comment 3 Warren Togami 2002-08-23 06:03:57 EDT
ESD is still not enabled by default in Null.
Comment 4 Havoc Pennington 2002-08-23 09:27:59 EDT
sopwith made some changes to libgnomeui/control-center/esound in rawhide 
that may have things working.
Comment 5 Havoc Pennington 2002-08-23 12:16:26 EDT
We believe this is fixed, xmms etc. should work now.
Comment 6 Jay Turner 2002-09-03 08:51:57 EDT
Fix confirmed with libgnome-2.0.2-5.

Note You need to log in before you can comment on or make changes to this bug.