Bug 71397 - no sound untill esd is killed
no sound untill esd is killed
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: esound (Show other bugs)
beta4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 66256 70254 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-12 20:28 EDT by Chris Runge
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-23 16:35:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2002-08-12 20:28:38 EDT
Description of Problem:

Milan 4 / Limbo 2

I'm running basically the standard Workstation installation type and
can't get hardly any sound by default under GNOME. The only app that
gives me sound (I have a detected SB Live!) is Chromium. Diving deeper
into the problem it appears that esd is started automatically (even
thought it is turned off in the sound preferences) and that programs
that use sound through esd don't actually play sound. 

Issuing a killall esd solves the problem temporarily. All programs then
play sound--xmms, tuxracer, playwave, etc.--all work fine. 

Version-Release number of selected component (if applicable):

esound-0.2.27-2

How Reproducible:

100%

Steps to Reproduce:
1. install Workstation class
2. start GNOME
3. try to start an app that plays sound (e.g., xmms, tuxracer)

Actual Results:


Expected Results:


Additional Information:
Comment 1 Havoc Pennington 2002-08-13 15:37:15 EDT
See also bug 71393
Comment 2 Chris Runge 2002-08-22 16:46:38 EDT
still a problem in Null -- any ideas?
Comment 3 Chris Runge 2002-08-22 16:48:31 EDT
can I see 67217? (I don't have permission right now)
Comment 4 Havoc Pennington 2002-08-22 17:05:04 EDT
I think this is fixed in rawhide, sopwith can give details.

67217 is an internal tracking bug, not related to the technical issue.
Comment 5 Havoc Pennington 2002-08-23 12:13:59 EDT
OK, we believe this to be fixed now. Need control-center libgnomeui esound 
updated packages to test.
Comment 6 Elliot Lee 2002-08-23 16:31:16 EDT
*** Bug 66256 has been marked as a duplicate of this bug. ***
Comment 7 Elliot Lee 2002-08-23 16:34:57 EDT
*** Bug 70254 has been marked as a duplicate of this bug. ***
Comment 8 Jay Turner 2002-08-30 00:23:25 EDT
Fix confirmed with control-center-2.0.1-7 and libgnomeui-2.0.3-2.
Comment 9 Jim Hall 2002-09-01 14:12:11 EDT
FWIW: I had the exact same problem .. could play sound only from the command
line, but X apps (such as xmms) would not play sound.  Updating to these RPMs
fixed sound from X apps (from GNOME) under the Red Hat Public Beta "(null)":

control-center-2.0.1-7.i386.rpm
libgnomeui-2.0.3-3.i386.rpm
libgnomeui-devel-2.0.3-3.i386.rpm


These were on rawhide as of this afternoon (1PM US/Central.)

-jh

Note You need to log in before you can comment on or make changes to this bug.