Bug 71416 - crashes on "Misc" diagrams
crashes on "Misc" diagrams
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: dia (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
: 71418 (view as bug list)
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-13 07:58 EDT by Harald Hoyer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 22:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2002-08-13 07:58:31 EDT
$ LANG=C dia
libpng warning: Application was compiled with png.h from libpng-1.2.2
libpng warning: Application  is  running with png.c from libpng-1.0.13
libpng error: Incompatible libpng version in application and library

Gtk-CRITICAL **: file gtkcontainer.c: line 713 (gtk_container_add): assertion
`widget != NULL' failed.
libpng warning: Application was compiled with png.h from libpng-1.2.2
libpng warning: Application  is  running with png.c from libpng-1.0.13
libpng error: Incompatible libpng version in application and library
libpng warning: Application was compiled with png.h from libpng-1.2.2
libpng warning: Application  is  running with png.c from libpng-1.0.13
libpng error: Incompatible libpng version in application and library
Gdk-ERROR **: BadPixmap (invalid Pixmap parameter)
  serial 10017 error_code 4 request_code 56 minor_code 0
Comment 1 Harald Hoyer 2002-08-13 07:59:28 EDT
since this is in the Main Menu "Office" I set "Milan Blocker"
Comment 2 Havoc Pennington 2002-08-13 11:34:53 EDT
makefile screwup with libpng
Comment 3 Havoc Pennington 2002-08-13 11:36:38 EDT
*** Bug 71418 has been marked as a duplicate of this bug. ***
Comment 4 Havoc Pennington 2002-08-13 22:18:43 EDT
0.90-5 theoretically fixes this. We had left the patch in dia to use libpng10
after deciding to move gdk-pixbuf to libpng12.
Comment 5 Jay Turner 2002-08-14 12:56:22 EDT
No longer getting the error messages with dia-0.90-5, so closing out.

Note You need to log in before you can comment on or make changes to this bug.