Bug 71443 - traceback uninstalling and installing
Summary: traceback uninstalling and installing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
: 71529 (view as bug list)
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-08-13 18:26 UTC by Tammy Fox
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-19 05:02:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tammy Fox 2002-08-13 18:26:30 UTC
I unselected galeon and clicked Update. I get this traceback
with version 0.8-1:

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 57, in response_cb
    self.im.setupTransaction(comps, progress_dialog)
  File "/usr/share/redhat-config-packages/method.py", line 106, in setupTransaction
    unresolvable_dependencies = comps.verifyDeps("/", 1, dialog.update)
  File "/usr/share/redhat-config-packages/comps.py", line 687, in verifyDeps
    ts.remove(p.h[rpm.RPMTAG_NAME])
rpm404.error: package not installed


But, the galeon package is installed.

Comment 1 Tammy Fox 2002-08-14 20:14:17 UTC
I got this again when trying to install the DNS Name Server group.

Comment 2 Jeremy Katz 2002-08-16 10:05:33 UTC
Were you doing multiple operations (ie, doing an install, going back to the UI,
doing an uninstall, etc?)

Comment 3 Tammy Fox 2002-08-16 14:33:33 UTC
Yes.

Comment 4 Jeremy Katz 2002-08-18 17:24:35 UTC
Need to decide if we're either going to reset the state after you do an install
of a group of packages or exit after this.  My initial leanings were toward the
latter, but the more I think about it, the more the former seems like the right
answer

Comment 5 Jeremy Katz 2002-08-18 17:25:24 UTC
*** Bug 71529 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2002-08-19 05:02:37 UTC
Properly set state to NOT_INSTALLED after package removal now in CVS, which
should fix this

Comment 7 Jay Turner 2002-08-20 17:09:52 UTC
Fix confirmed with redhat-config-packages-0.91-1.


Note You need to log in before you can comment on or make changes to this bug.