This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 71457 - error installing filesystem-2.1.6-2 due to /usr/tmp partition
error installing filesystem-2.1.6-2 due to /usr/tmp partition
Status: CLOSED DUPLICATE of bug 75343
Product: Red Hat Linux
Classification: Retired
Component: filesystem (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-13 16:26 EDT by Jan Mason
Modified: 2014-03-16 22:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-13 16:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Mason 2002-08-13 16:26:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
This occurs with both a fresh install of 7.3 or an upgrade from 7.2 to 7.3. 
When the installation/upgrade 
process gets to the Installing Packages section and actually starts
installing packages I get the following error when the package for
filesystem-2.1.6-2 is installed:

++++++++++++++++++++++++++++++++++++++++++++++++++++
There was an error installing filesystem-2.1.6-2.
This can indicate media failure, lack of disk
space, and/or hardware problems.  This is a fatal
error and your install will be aborted.  Please
verify your media and try your install again.

Press the OK button to reboot your system.
~                                           OK
++++++++++++++++++++++++++++++++++++++++++++++++++++ 



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Fresh install of 7.3 or upgrade from 7.2 to 7.3.
2. Set up a /usr/tmp partition during the install/upgrade.

	

Actual Results:  When the upgrade process gets to the Installing Packages
section and actually starts installing packages I get the following error when
the package for filesystem-2.1.6-2 is installed:

++++++++++++++++++++++++++++++++++++++++++++++++++++
There was an error installing filesystem-2.1.6-2.
This can indicate media failure, lack of disk
space, and/or hardware problems.  This is a fatal
error and your install will be aborted.  Please
verify your media and try your install again.

Press the OK button to reboot your system.
                                          OK
++++++++++++++++++++++++++++++++++++++++++++++++++++

In the /root/upgrade.log file (from the last 7.3 upgrade):
Upgrading filesystem-2.1.6-2.
unpacking of archive failed on file /usr/tmp: cpio: rename failed -
    Is a directory

There is a directory called: /usr/tmp (which is its own partition)
There are also two different symbolic links to /var/tmp.
The time stamps show that they are from the last clean install and the
last upgrade.

In the /tmp/install.log which was for the 7.2 fresh install file showed that it
failed but the install continued.  In 7.3 the exact same error is fatal and the
install stops.

Expected Results:  The file system package should have installed/upgraded with
no problems or the error message should have told me that the partition /usr/tmp
was an invalid partition.

Additional info:

I have run all version of Red Hat on this computer since 4.1.
This problem occured in 7.2 but was not a show stopper as it was in 7.3.
I deleted the /usr/tmp partition and did a fresh install with no problem.
Comment 1 Bill Nottingham 2002-11-20 16:16:29 EST

*** This bug has been marked as a duplicate of 75343 ***

Note You need to log in before you can comment on or make changes to this bug.