Bug 71488 - modemlights_applet unable to handle more than one connection
modemlights_applet unable to handle more than one connection
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: gnome-applets (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-14 04:59 EDT by Nils Philippsen
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-10 02:27:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2002-08-14 04:59:48 EDT
Description of Problem:

Starting more than one of modemlights_applet causes the older configuration to
be overwritten, resulting in all modemlights_applets using the new configuration.

Version-Release number of selected component (if applicable):

gnome-applets-2.0.1-2

How Reproducible:

Always.

Steps to Reproduce:
1. Start modemlights_applet
2. Configure applet
3. Start second modelights_applet

Actual Results:

Configuration of first applet gets overwritten with that of the second one.

Expected Results:

Each modemlights_applet has its own configuration (just like in Gnome 1.x)
Comment 1 Havoc Pennington 2002-08-19 14:52:42 EDT
That's strange, source code looks like it saves properties the same way as any
other applet.
Comment 2 Nils Philippsen 2002-08-19 17:36:31 EDT
Just confirmed the error with gnome-applets-2.0.1-3 and GConf2-1.2.1-1 (having
one modemlights_applet for cipcb0 and adding a second one overwrites the first
one's configuration with standard settings (ppp0)).

And yes, this time I mean the modemlights_applet.
Comment 3 Havoc Pennington 2003-01-12 21:48:19 EST
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=103281
Comment 4 Nils Philippsen 2003-05-19 04:54:20 EDT
Upstream closed it in CVS:

http://bugzilla.gnome.org/show_bug.cgi?id=100007

Changed RHL version to 9.
Comment 5 Nils Philippsen 2003-09-10 02:27:03 EDT
Seems to be fixed in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.