Bug 715067 - rg_test is missing resource-defaults capability
rg_test is missing resource-defaults capability
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager (Show other bugs)
6.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-21 14:45 EDT by Lon Hohberger
Modified: 2011-06-21 14:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-21 14:52:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2011-06-21 14:45:16 EDT
Description of problem:

The resource-defaults section in cluster.conf allows administrators to override resource-agent specified defaults for a given class of resource.

rg_test is missing the call to load_resource_defaults() which would correctly set the information.  This was found during testing of bug 707118.

Version-Release number of selected component (if applicable): 3.0.12.1-1

How reproducible:

Steps to Reproduce:
1. add <resource-defaults> section to cluster.conf
2. run rg_test on the cluster.conf
  
Actual results: No changes to defaults based on what was added.

Expected results: Changes to defaults

Additional info:  This was found during testing of bug 707118.
Comment 1 Lon Hohberger 2011-06-21 14:52:17 EDT
Upon further investigation, this was user error; I had placed the resource-defaults section in the wrong location in cluster.conf.

Happy days.

Note You need to log in before you can comment on or make changes to this bug.