Bug 715265 - Oracle DB installation unnecessarily starts the listener before it's correctly set up
Oracle DB installation unnecessarily starts the listener before it's correctl...
Status: CLOSED DEFERRED
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
540
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2011-06-22 07:43 EDT by Milan Zazrivec
Modified: 2014-07-04 09:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-04 09:26:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2011-06-22 07:43:06 EDT
Description of problem:
Installation of Oracle database (not installation of the oracle-server
package itself, but installation of catalog, db setup, etc...)
unnecessarily starts the listener before the listener is properly setup.

Starting the listener without a proper listener.ora leads to the listener
to be connecting to 0.0.0.0 (its internal default behavior), which will
fail in an IPv6 only setup.

Version-Release number of selected component (if applicable):
oracle-server-scripts-10.2.0.51-6

How reproducible:
Always

Steps to Reproduce:
1. IPv6 only environment, Satellite 5.4.1 installation
2. Check /var/log/rhn/install_db.log 
  
Actual results:
Error:

Starting /opt/apps/oracle/web/product/10.2.0/db_1/bin/tnslsnr: please wait...

TNSLSNR for Linux: Version 10.2.0.4.0 - Production
Log messages written to /opt/apps/oracle/web/product/10.2.0/db_1/network/log/listener.log
Error listening on: (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
TNS-12545: Connect failed because target host or object does not exist
 TNS-12560: TNS:protocol adapter error
  TNS-00515: Connect failed because target host or object does not exist


Listener failed to start. See the error message(s) above...

Expected results:
No error like the above.

Additional info:
This error is not fatal to the installation, but should probably be resolved
for a smooth Satellite IPv6 installation.

Note You need to log in before you can comment on or make changes to this bug.