Bug 715285 - avc: denied { sys_tty_config } for ... comm="sa1" ... scontext=root:system_r:sysstat_t:s0 tcontext=root:system_r:sysstat_t:s0 ...
avc: denied { sys_tty_config } for ... comm="sa1" ... scontext=root:system_r:...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.7
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 08:37 EDT by Milos Malik
Modified: 2012-09-24 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-317.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:47:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2011-06-22 08:37:46 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-2.4.6-313.el5
selinux-policy-targeted-2.4.6-313.el5

How reproducible:
sometimes

Steps to Reproduce:
* run following automated test on fresh ia64 machine where RHEL-5.7 is installed
/CoreOS/selinux-policy/Regression/bz485078-wrong-context-for-sysstat
  
Actual results:
----
time->Wed Jun 22 07:07:09 2011
type=SYSCALL msg=audit(1308740829.064:762): arch=c0000032 syscall=1065 success=yes exit=0 a0=0 a1=5401 a2=60000fffff92a940 a3=0 items=0 ppid=30638 pid=30639 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="sa1" exe="/bin/bash" subj=root:system_r:sysstat_t:s0 key=(null)
type=AVC msg=audit(1308740829.064:762): avc:  denied  { sys_tty_config } for  pid=30639 comm="sa1" capability=26 scontext=root:system_r:sysstat_t:s0 tcontext=root:system_r:sysstat_t:s0 tclass=capability
----

Expected results:
no AVCs
Comment 2 Daniel Walsh 2011-06-22 09:49:57 EDT
We allow this in RHEL6.
Comment 3 Miroslav Grepl 2011-09-29 07:32:16 EDT
Fixed in selinux-policy-2.4.6-317.el5
Comment 6 errata-xmlrpc 2012-02-21 00:47:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html

Note You need to log in before you can comment on or make changes to this bug.