This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715286 - Fix inconsistent permissions fixing on /var/cache/mock in SPEC template
Fix inconsistent permissions fixing on /var/cache/mock in SPEC template
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 08:41 EDT by Yury V. Zaytsev
Modified: 2011-10-16 14:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: mock-1.1.15-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-02 19:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Trivial fix (643 bytes, patch)
2011-06-22 08:43 EDT, Yury V. Zaytsev
no flags Details | Diff
Additional fix (722 bytes, patch)
2011-06-22 09:03 EDT, Yury V. Zaytsev
no flags Details | Diff
Yet another bug in the SPEC, this time /var/{lib,cache}/permissions were not set correctly in the files section (883 bytes, patch)
2011-06-23 08:28 EDT, Yury V. Zaytsev
no flags Details | Diff

  None (edit)
Description Yury V. Zaytsev 2011-06-22 08:41:10 EDT
Actual results:

/var/cache/mock is declared 2775 in setup, then overridden in postinstall

Expected results:

/var/cache/mock should be 2775 everywhere

Additional info:

Please see patch attached.
Comment 1 Yury V. Zaytsev 2011-06-22 08:43:46 EDT
Created attachment 505994 [details]
Trivial fix
Comment 2 Yury V. Zaytsev 2011-06-22 09:03:09 EDT
Created attachment 505999 [details]
Additional fix

Additionally, it does not make sense to set /var/cache/mock to 2775 upon %install because it's done in %files anyway. Needless duplication clutters the SPEC and makes it harder to maintain.
Comment 3 Clark Williams 2011-06-22 10:09:09 EDT
Thanks, I've added your patches (I combined the two into one git commit) for the next release.
Comment 4 Yury V. Zaytsev 2011-06-23 08:28:16 EDT
Created attachment 506226 [details]
Yet another bug in the SPEC, this time /var/{lib,cache}/permissions were not set correctly in the files section

Hi!

You are quite welcome; thanks for the prompt reaction. There seems to be yet another bug, however. The %attr macro as used in the SPEC only applies to *files*, not *directories*, thus the permissions were not being set correctly on the lib folder (not sure how important is that).

This bug would surface with the cache directory if one day the fix from %post will be removed and it hit me already on a clean install.

Thanks!
Comment 5 Yury V. Zaytsev 2011-06-23 08:32:22 EDT
Additionally, as I noted in an e-mail, it would be nice to have the tarballs updated on the FedoraHosted page. I can do this for you, but I need an account :-/
Comment 6 Yury V. Zaytsev 2011-09-21 13:28:23 EDT
The last patch (attachment 506226 [details]) is still relevant.
Comment 7 Clark Williams 2011-09-23 14:58:37 EDT
Ok, queued for the 1.1.15 release
Comment 8 Fedora Update System 2011-09-23 16:55:27 EDT
mock-1.1.15-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.fc15
Comment 9 Fedora Update System 2011-09-23 16:56:29 EDT
mock-1.1.15-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.el6
Comment 10 Fedora Update System 2011-09-23 16:57:23 EDT
mock-1.0.22-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/mock-1.0.22-1.el5
Comment 11 Fedora Update System 2011-09-23 16:58:13 EDT
mock-1.1.15-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/mock-1.1.15-1.fc14
Comment 12 Fedora Update System 2011-09-24 17:59:40 EDT
Package mock-1.1.15-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mock-1.1.15-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/mock-1.1.15-1.el6
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2011-10-02 18:59:58 EDT
mock-1.1.15-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2011-10-02 19:08:24 EDT
mock-1.1.15-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2011-10-16 14:27:58 EDT
mock-1.0.22-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2011-10-16 14:29:45 EDT
mock-1.1.15-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.