This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715367 - FPC guideline update that impacts naming of extensions
FPC guideline update that impacts naming of extensions
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 12:39 EDT by Toshio Ernie Kuratomi
Modified: 2011-08-30 21:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: gnome-shell-extensions-3.0.2-3.20110630git939994d0.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 16:35:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for gnome-shell-extensions.spec (12.48 KB, patch)
2011-08-21 10:15 EDT, Michel Alexandre Salim
no flags Details | Diff
Patch for gnome-shell-extensions.spec (12.49 KB, patch)
2011-08-21 10:35 EDT, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Toshio Ernie Kuratomi 2011-06-22 12:39:04 EDT
Description of problem:

The Fedora Packaging Committee decided today on a consistent manner to name packages containing extensions to gnome shell.  The format is gnome-shell-extension-foo (no "s" in extension).

During the meeting, how gnome-shell-extensions fit into that was discussed.  We arrived at the following conclusions:

* The addon naming guidelines should supercede the subpackage naming guidelines in this case.

* Since we normally grandfather packages when we update the naming guidelines we wouldn't require that names of the currently existing gnome-shell-extensions be changed.

* However, especially since there's no re-review needed, it's highly desirable that the subpackages be renamed to that form (With %package -n gnome-shell-extension-alternate-tab for instance).  If you would like to do it so that end-users get consistent package names we'd appreciate the effort.

* Any additional subpackages that are built from this package in the future should use gnome-shell-extension-FOO rather than gnome-shell-extensions-FOO.

Thanks.
Comment 1 Michel Alexandre Salim 2011-08-21 10:15:40 EDT
Created attachment 519181 [details]
Patch for gnome-shell-extensions.spec

This patch updates the spec file to comply with the new packaging guidelines, while providing an upgrade path for existing installed packages.

Please comment if you find anything wrong with it, otherwise I'll commit it and work on updating g-s-e for F-16 and rawhide.
Comment 2 Michel Alexandre Salim 2011-08-21 10:35:27 EDT
Created attachment 519183 [details]
Patch for gnome-shell-extensions.spec

Fixes typo in earlier patch
Comment 3 Toshio Ernie Kuratomi 2011-08-21 11:07:56 EDT
Thanks, the change looks good to me.
Comment 4 Mohamed El Morabity 2011-08-21 11:23:53 EDT
Thanks for your patch :).
Anyway, do you really think it's pertinent to rename also the common package? gnome-shell-extension(s)-common is not an extension, just files shared by all GS extensions.
Comment 5 Michel Alexandre Salim 2011-08-21 14:12:56 EDT
I'm not 100% sure on the -common subpackage; however, it seems a bit odd if that's the only gnome-shell-extensions-* package, and everything else is gnome-shell-extension-*
Comment 6 Fedora Update System 2011-08-21 14:48:55 EDT
gnome-shell-extensions-3.0.2-3.20110630git939994d0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.0.2-3.20110630git939994d0.fc15
Comment 7 Fedora Update System 2011-08-21 14:49:06 EDT
gnome-shell-extensions-3.1.4-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.1.4-2.fc16
Comment 8 Fedora Update System 2011-08-22 14:36:10 EDT
Package gnome-shell-extensions-3.1.4-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-shell-extensions-3.1.4-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gnome-shell-extensions-3.1.4-2.fc16
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2011-08-30 16:35:32 EDT
gnome-shell-extensions-3.1.4-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2011-08-30 21:24:41 EDT
gnome-shell-extensions-3.0.2-3.20110630git939994d0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.