This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 715459 - KDE's wireless broken on secure AP w/ "hidden" setup
KDE's wireless broken on secure AP w/ "hidden" setup
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kde-plasma-networkmanagement (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lukáš Tinkl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 19:38 EDT by Jerry Amundson
Modified: 2015-07-13 13:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-27 18:59:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 209464 None None None Never

  None (edit)
Description Jerry Amundson 2011-06-22 19:38:07 EDT
Description of problem:
KDE's wireless broken on secure AP w/ "hidden" setup

Version-Release number of selected component (if applicable):
kde-plasma-networkmanagement-0.9-0.47.20110323.fc15

How reproducible:
always 

Steps to Reproduce:
1. login to KDE, and click the (useless) dot for NM access
2. enter hidden AP's name
3. 
  
Actual results:
Nothing

Expected results:
Setup of the hidden access point

Additional info:

From .xsession-errors...

Usage: networkmanagement_configshell [Qt-options] [KDE-options] [options] mode 

Create network connections standalone

Generic options:
  --help                    Show help about options
  --help-qt                 Show Qt specific options
  --help-kde                Show KDE specific options
  --help-all                Show all options
  --author                  Show author information
  -v, --version             Show version information
  --license                 Show license information
  --                        End of options

Options:
  --connection <connection-id> Connection ID to edit
  --hiddennetwork <ssid>    Connect to a hidden wireless network
  --type <type>             Connection type to create, must be one of '802-3-ethernet', '802-11-wireless', 'pppoe', 'vpn', 'cellular'
  --specific-args <args>    Space-separated connection type-specific arguments, may be either 'gsm' or 'cdma' for cellular, or 'openvpn' or 'vpnc' for vpn connections, and interface and AP identifiers for wireless connections

Arguments:
  mode                      Operation mode, may be either 'create' or 'edit'
Comment 1 Jerry Amundson 2011-06-22 19:39:55 EDT
(In reply to comment #0)
> 
> Steps to Reproduce:
> 1. login to KDE, and click the (useless) dot for NM access
> 2. enter hidden AP's name

Current test was done from the KDE Live CD.
Comment 2 Fedora Update System 2011-09-09 19:16:26 EDT
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-11509
Comment 3 collura 2011-09-13 01:40:37 EDT
bummer missed inclusion in f16-beta-tc2 livecd 
which think only had up to 
kde-plasma-networkmanagement-1:0.9-0.54.20110812git.nm09.fc16 
and thus still hadnt worked.  but we almost there :')
Comment 4 Kevin Kofler 2011-09-13 11:04:15 EDT
The update will probably go stable only after the Beta. (IIRC, the change deadline for the beta was yesterday, and the update has been in testing only for 3 days.)
Comment 5 Fedora Update System 2011-09-15 13:47:30 EDT
kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15
Comment 6 Fedora Update System 2011-09-15 22:00:44 EDT
Package kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15
then log in and leave karma (feedback).
Comment 7 collura 2011-09-19 14:13:06 EDT
got bogged down so missed the 
   kde-plasma-networkmanagement-0.9-0.57.20110907git.nm09.fc15 
test going through, 
but i did just run across the
   kde-plasma-networkmanagement-0.9-0.58.20110918git.nm09.fc15
test which i tried and can report that by that time it certainly does fix things nicely :')

if i try to name a hidden network in the plasma applet it dutifully pops up the network definition interface so i can enter the connection info.

used the restrict to interface option and used with/without the 'system' checkbox (yay option to save typing wallet password at reboot).
works great.

doh, cant seem to find the associated 
  admin.fedoraproject.org/updates/kde-plasma-networkmangement-0.9-0.58.20110918git.nm09.fc15
link to post a 'works' response to...
 
...but thought i had clicked on the link during the install so not sure if it brought up a link for 0.9-0.59.20110919git.nm09.fc15 by way of a typo in that link in the update description, or server being updated, or what.  


thanks for the work on the long awaited shiny new wireless applet.

i will work on the fire, someone round up the minstrals.
Comment 8 Kevin Kofler 2011-09-19 14:56:42 EDT
> ...but thought i had clicked on the link during the install so not sure if it
> brought up a link for 0.9-0.59.20110919git.nm09.fc15 by way of a typo in that
> link in the update description, or server being updated, or what.  

It's just that I updated the update again (to fix https://bugs.kde.org/show_bug.cgi?id=282282 , an issue with OpenConnect VPN). :-)
Comment 9 collura 2011-09-20 16:25:42 EDT
yeah figured it should be something like that :')

thought i should have been able to see the old link when i searched admin  
because i could find the august updates still in the admin list but not the 0918 one 

and since the 0919 one didnt seem to be released to testing, so i were confuse, lol ;')
Comment 10 Fedora Update System 2011-09-27 18:58:49 EDT
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-09-30 14:50:59 EDT
kde-plasma-networkmanagement-0.9-0.59.20110919git.nm09.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.