This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 71575 - Application should show current status of services
Application should show current status of services
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-services (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 06:19 EDT by Mike MacCana
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 15:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2002-08-15 06:19:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020724

Description of problem:
The service config application would be much more useful if it showed the
services current status.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Service configuration
2a.Try and find out the current status of a service, OR
2b. Start a service. Wait for feedback.

	

Actual Results:  There should be status information for services. It should be
updated when that service is started or stopped or restarted. 

Additional info:
Comment 1 Daniel Walsh 2002-08-22 13:15:28 EDT
I am not sure this is possible.  A service is not necessarily running.  The name
of the service does not correspond to the name of daemons that are running.  For
instance the nfs service starts multiple nfsd's.  A service is something that
starts at different runlevels.  Maybe a tool like redhat-config-processes might be
closer to what you want.
Comment 2 Mike MacCana 2002-08-22 20:51:51 EDT
Thanks for your reply. 
 
> Maybe a tool like redhat-config-processes might be closer to what you want.  
 
I'd really like to automate the `Open Services, check state on command line' 
cycle. In fact, I probably don't think that cycle would happen - most users 
would probably do everything from the command line simply (even if they 
preferred a graphical app) because services can't tell them all the things the 
`service' command does. 
 
I'm really looking for something that provides the equivalent of the status 
parameter in Services. I see as possible to implement and suitable for the 
services app  (will explain why in a sec) ang I think it will give users the 
feedback they expect when starting or stopping services - they're already 
using `service (service) status' for this, it seems sensible to put somethign 
similar in the app.   
  
> For instance the nfs service starts multiple nfsd's.   
Indeed - and ldap starts both slapd and slurpd, etc. The way I see things that 
sholdn't be a problem. Each application would have a definition of what 
constitutes a sane running state. The Linux Standards Base allows Red Hat to 
put this information in the initscript if we wish (there's already similar 
information there), or somewhere else may be more appropriate. For example: 
 
nfs: at least one instance of rpc.mountd, and at least one of nfsd.  
ldap: at least one slapd and slurpd  
etc. 
 
In Services, each application can be in one of the following states:  
  
green - the system is in its sane state 
dark green - for application like Kudzu and Netfs - services which are not 
deamons. As you mentioned, a service is not necessarily running - this lets 
users know that these services are OK. 
yellow - the system is not in its sane state 
red - the service is not running, lockfile removed, etc. 
 
Users can click/hover on a service's state to get more info - basically the 
same stuff that you get with the sstatus parameter, telling you exactly what 
processes are running. 
  
Thanks for your I hope that's addressed your concern, and I hope you don't 
mind me reopening the bug.
Comment 3 Mike MacCana 2002-08-22 20:52:25 EDT
Thanks for your reply. 
 
> Maybe a tool like redhat-config-processes might be closer to what you want.  
 
I'd really like to automate the `Open Services, check state on command line' 
cycle. In fact, I probably don't think that cycle would happen - most users 
would probably do everything from the command line simply (even if they 
preferred a graphical app) because services can't tell them all the things the 
`service' command does. 
 
I'm really looking for something that provides the equivalent of the status 
parameter in Services. I see as possible to implement and suitable for the 
services app  (will explain why in a sec) ang I think it will give users the 
feedback they expect when starting or stopping services - they're already 
using `service (service) status' for this, it seems sensible to put somethign 
similar in the app.   
  
> For instance the nfs service starts multiple nfsd's.   
Indeed - and ldap starts both slapd and slurpd, etc. The way I see things that 
sholdn't be a problem. Each application would have a definition of what 
constitutes a sane running state. The Linux Standards Base allows Red Hat to 
put this information in the initscript if we wish (there's already similar 
information there), or somewhere else may be more appropriate. For example: 
 
nfs: at least one instance of rpc.mountd, and at least one of nfsd.  
ldap: at least one slapd and slurpd  
etc. 
 
In Services, each application can be in one of the following states:  
  
green - the system is in its sane state 
dark green - for application like Kudzu and Netfs - services which are not 
deamons. As you mentioned, a service is not necessarily running - this lets 
users know that these services are OK. 
yellow - the system is not in its sane state 
red - the service is not running, lockfile removed, etc. 
 
Users can click/hover on a service's state to get more info - basically the 
same stuff that you get with the sstatus parameter, telling you exactly what 
processes are running. 
  
Thanks for your I hope that's addressed your concern, and I hope you don't 
mind me reopening the bug.
Comment 4 Mike MacCana 2002-08-22 20:53:36 EDT
Erk, sorry about the duplicate.
Comment 5 Daniel Walsh 2002-08-23 12:25:53 EDT
I will make some changes to serviceconf to reflect the status after the next
release of redhat.  It is too late to get changes into milan.  Good ideas though.
Thanks.
Comment 6 Daniel Walsh 2002-10-02 11:05:45 EDT
Fixed in redhat-config-services-0.8.3-1.

This will be in rawhide soon.

Note You need to log in before you can comment on or make changes to this bug.