Bug 71578 - Consistently name packages: rename httpd to apache / rename other packages to match
Consistently name packages: rename httpd to apache / rename other packages to...
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: httpd (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 07:26 EDT by Mike MacCana
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-15 14:56:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike MacCana 2002-08-15 07:26:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020712

Description of problem:
Red Hat needs a consistent naming policy with regard to packages / services. 

It seems that the apache (an implementation of an httpd) package has been
renamed httpd after the service it provides. This seems odd, as there are many
implementations of httpd for Linux which are not apache (thttpd, for example).

If Red Hat choose to keep apache as a package called httpd, this logic should be
applied to all other packages Red Hat uses, renaming the implementations to the
generic service provided. 
vsftpd -> ftpd
openssh-servers -> sshd
bind -> named
sendmail / postfix - smtpd
etc. But this has the obvious flaw of choosing one particular implementation to
recieve the generic `(protocol)d' package name. A problem also presents itself
if Red Hat changes their default implementation from postfix - sendmail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install bind, sendmail, postfix, openssh-servers, vsftpd, etc packages. Note
they are all named after the actual implementation, not the protocol being served.  


Actual Results:  1.Wonder why apache is no longer named after the
implementation, but the protocol
2.Wonder why this isn't consistent with most other packages
3.Wonder if the httpd package contains apache or httpd or aolserver
4.Wonder that happens if Red Hat changes their mind and another package provides
the httpd, what httpd will then be replaced with?
	

Expected Results:  The apache -> httpd rename seems like a really bad idea. But
even if it isn't. Red Hat need some consistent policy for naming packages.

Additional info:
Comment 1 Miloslav Trmac 2002-08-15 14:56:01 EDT
That's because the Apache foundation now calls the web server "httpd". Search
limbo-list archives for more info.
Comment 2 Joe Orton 2002-08-22 06:37:11 EDT
Indeed; this change is to be consistent with the Apache Software Foundation
naming policy.

Note You need to log in before you can comment on or make changes to this bug.