Bug 71595 - Fix off by one pixel errors by applying attached patch
Fix off by one pixel errors by applying attached patch
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 10:56 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 07:17:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes off by one pixel problems in the Mozilla 1.0.x branch (5.57 KB, patch)
2002-08-15 10:58 EDT, Nathan G. Grennan
no flags Details | Diff

  None (edit)
Description Nathan G. Grennan 2002-08-15 10:56:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Mozilla 1.0.0, 1.0.1, and trunk all still have bugs with the renderer rounding
numbers and being off by one pixel. Weeks ago I found a patch to fix then in the
1.0.x branch. It doesn't work in the trunk because of other chances and some of
the bugs have been fixed, but other off by one pixel bugs are still in the trunk.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	

Additional info:

Fixes off by one pixel scrolling problems
Fixes off by one pixel selecting text problems
Comment 1 Nathan G. Grennan 2002-08-15 10:58:06 EDT
Created attachment 70846 [details]
Fixes off by one pixel problems in the Mozilla 1.0.x branch
Comment 2 Barry K. Nathan 2002-08-16 03:31:38 EDT
Why does the summary say "RFE"? This doesn't look to me like an enhancement
request -- rather, it looks like a request to add a workaround for a bug.
"workaround for a bug" != "enhancement", at least in my opinion...

BTW, as far as I understand, a real fix for the off-by-one scrolling problems
was committed to the 1.0.1 branch and the trunk. You might want to take a look
at this bug in Mozilla's Bugzilla (where I believe your patch originally came
from): http://bugzilla.mozilla.org/show_bug.cgi?id=80530

(I haven't followed the progress on the off-by-one selection bug though.)
Comment 3 Nathan G. Grennan 2002-08-16 11:05:26 EDT
As far as I know nothing has been applied too the 1.0.1 branch. I still see off
by one problems with mozilla-1.0.1-15. This patch applies without need of
modification and fixes the problems I see.
Comment 4 Nathan G. Grennan 2003-01-15 07:17:58 EST
Mozilla has since been upgrade to 1.2.1 in rawhide and the patch I mentioned
won't apply. I have since been able to work around this bug by tweaking
settings. Hopefully it will one day get fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.