Bug 71610 - glib2-2.0.6-1 build errors
glib2-2.0.6-1 build errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: glib2 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 13:51 EDT by R P Herrold
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-31 19:35:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-08-15 13:51:46 EDT
looks like a missing build dependency on glib-devel ... it is requireing a
pre-existing '-lglib-2.0' which seems wrong -- BUT: it should not need a prior
version of itselt to build itself.  This breaks clean bootstrapping.

Building from src with the current Raw Hide and a fairly minimal install:

<snip>
libtool: install: warning: relinking `libgthread-2.0.la'
(cd /usr/src/redhat/BUILD/glib-2.0.6/gthread; /bin/sh ../libtool --mode=relink
i386-redhat-linux-gcc -O2 -march=i386 -mcpu=i686 -Wall -D_REENTRANT -o
libgthread-2.0.la -rpath /usr/lib -version-info 0:6:0 -export-dynamic
gthread-impl.lo -lpthread ../glib/libglib-2.0.la)
i386-redhat-linux-gcc -shared  gthread-impl.lo  -lpthread -L/usr/lib
-lglib-2.0   -Wl,-soname -Wl,libgthread-2.0.so.0 -o
.libs/libgthread-2.0.so.0.0.6
/usr/bin/ld: cannot find -lglib-2.0
collect2: ld returned 1 exit status
libtool: install: error: relink `libgthread-2.0.la' with the above command
before installing it
libtool: install: warning: remember to run `libtool --finish /usr/lib'
make[2]: Nothing to be done for `install-data-am'.

<snip>
make[1]: Leaving directory `/usr/src/redhat/BUILD/glib-2.0.6/docs'
+ /usr/lib/rpm/find-lang.sh /var/tmp/glib-2.0.6-root glib20
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: glib2-2.0.6-1
error: File not found by glob:
/var/tmp/glib-2.0.6-root/usr/lib/libgthread-2.0.so.*
error: File not found by glob:
/var/tmp/glib-2.0.6-root/usr/lib/libgmodule-2.0.so.*
error: File not found by glob:
/var/tmp/glib-2.0.6-root/usr/lib/libgobject-2.0.so.*
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.38438
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd glib-2.0.6
+ DOCDIR=/var/tmp/glib-2.0.6-root/usr/share/doc/glib2-2.0.6

<snip>
Requires: pkgconfig >= 0.8 glib2 = 2.0.6 ld-linux.so.2 libc.so.6
libglib-2.0.so.0 libgobject-2.0.so.0 /bin/sh /usr/bin/perl libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1) libc.so.6(GLIBC_2.1.3)
Conflicts: glib-devel <= 1.2.8
Obsoletes: glib-gtkbeta-devel

RPM build errors:
    File not found by glob: /var/tmp/glib-2.0.6-root/usr/lib/libgthread-2.0.so.*
    File not found by glob: /var/tmp/glib-2.0.6-root/usr/lib/libgmodule-2.0.so.*
    File not found by glob: /var/tmp/glib-2.0.6-root/usr/lib/libgobject-2.0.so.*
bash-2.05# rpm -Uvh  glib2-2.0.6-1.src.rpm

bash-2.05#  rpm -q redhat-release
redhat-release-7.2-1
bash-2.05#

(my test host -- eagle.bench.lan)
Comment 1 Owen Taylor 2002-08-15 14:03:57 EDT
What's your libtool version? Looks like the package got
relibtoolized on your system with a libtool older than
1.4.2-10.
Comment 2 R P Herrold 2002-08-15 14:08:07 EDT
bash-2.05# rpm -q libtool
libtool-1.4.2-4
bash-2.05#
Comment 3 R P Herrold 2002-08-15 14:10:09 EDT
built new version of libtool and installed ...


Wrote: /usr/src/redhat/SRPMS/libtool-1.4.2-10.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/libtool-1.4.2-10.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/libtool-libs-1.4.2-10.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.29536
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd libtool-1.4.2
+ rm -rf /var/tmp/libtool-root
+ exit 0
bash-2.05# rpm -Uvh /usr/src/redhat/RPMS/i386/libtool-1.4.2-10.i386.rpm
/usr/src/redhat/RPMS/i386/libtool-libs-1.4.2-10.i386.rpm
Preparing...                ########################################### [100%]
   1:libtool-libs           ########################################### [ 50%]
   2:libtool                ########################################### [100%]
Comment 4 R P Herrold 2002-08-15 14:10:57 EDT
... so a versioned libtool BuildRequires is needed ?

... testing glib2 rebuild
Comment 5 R P Herrold 2002-08-15 14:14:20 EDT
yep -- that solved it:

Conflicts: glib-devel <= 1.2.8
Obsoletes: glib-gtkbeta-devel
Wrote: /usr/src/redhat/SRPMS/glib2-2.0.6-1.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/glib2-2.0.6-1.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/glib2-devel-2.0.6-1.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.27912
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd glib-2.0.6
+ rm -rf /var/tmp/glib-2.0.6-root
+ exit 0
bash-2.05#

Comment 6 Owen Taylor 2002-10-31 19:35:00 EST
Hmm, I don't see any reason why libtoolize got run.on your system.
Did it get run? 


Comment 7 R P Herrold 2002-10-31 21:20:24 EST
Recall that this is Raw Hide -- possibly in the libtool transition interval,
something wierd crept in.

I just got a clean rebuild thus:

$ rpmbuild  --rebuild glib2-2.0.6-3.src.rpm

-- Closing CURRVER

Note You need to log in before you can comment on or make changes to this bug.