Bug 71626 - autoconf error in Glide3-20010520-19.src.rpm ?
autoconf error in Glide3-20010520-19.src.rpm ?
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: automake14 (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-15 17:59 EDT by R P Herrold
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-16 14:36:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2002-08-15 17:59:52 EDT
All from R 7.2 stock, or Raw Hide this week


bash-2.05# rpmbuild -ba /usr/src/redhat/SPECS/Glide3.spec
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.11382
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf Glide3
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/Glide3-20010520.tar.bz2
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd Glide3
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ echo 'Patch #1 (Glide3-new-autotools-bugfix.patch):'
Patch #1 (Glide3-new-autotools-bugfix.patch):
+ patch -p0 -b --suffix .new-autotools-bugfix -s
+ echo 'Patch #10 (Glide3-redhat-cleanup-1.patch):'
Patch #10 (Glide3-redhat-cleanup-1.patch):
+ patch -p1 -b --suffix .redhat-cleanup-1 -s
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.1670
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd Glide3
+ pushd .
/usr/src/redhat/BUILD/Glide3 /usr/src/redhat/BUILD/Glide3
+ aclocal-1.4
aclocal: /usr/share/aclocal/ccstdc.m4: 23: duplicated macro `AM_PROG_CC_STDC'
aclocal: /usr/share/aclocal/cond.m4: 3: duplicated macro `AM_CONDITIONAL'
aclocal: /usr/share/aclocal/dmalloc.m4: 8: duplicated macro `AM_WITH_DMALLOC'
aclocal: /usr/share/aclocal/error.m4: 4: duplicated macro
`AM_FUNC_ERROR_AT_LINE'
aclocal: /usr/share/aclocal/header.m4: 3: duplicated macro `AM_CONFIG_HEADER'
aclocal: /usr/share/aclocal/init.m4: 10: duplicated macro `AM_INIT_AUTOMAKE'
aclocal: /usr/share/aclocal/lex.m4: 6: duplicated macro `AM_PROG_LEX'
aclocal: /usr/share/aclocal/lispdir.m4: 8: duplicated macro `AM_PATH_LISPDIR'
aclocal: /usr/share/aclocal/maintainer.m4: 6: duplicated macro
`AM_MAINTAINER_MODE'
aclocal: /usr/share/aclocal/missing.m4: 6: duplicated macro `AM_MISSING_PROG'
aclocal: /usr/share/aclocal/mktime.m4: 6: duplicated macro `AM_FUNC_MKTIME'
aclocal: /usr/share/aclocal/multi.m4: 4: duplicated macro `AM_ENABLE_MULTILIB'
aclocal: /usr/share/aclocal/obstack.m4: 4: duplicated macro `AM_FUNC_OBSTACK'
aclocal: /usr/share/aclocal/protos.m4: 8: duplicated macro `AM_C_PROTOTYPES'
aclocal: /usr/share/aclocal/ptrdiff.m4: 5: duplicated macro `AM_TYPE_PTRDIFF_T'
aclocal: /usr/share/aclocal/regex.m4: 17: duplicated macro `AM_WITH_REGEX'
aclocal: /usr/share/aclocal/sanity.m4: 5: duplicated macro `AM_SANITY_CHECK'
aclocal: /usr/share/aclocal/strtod.m4: 30: duplicated macro `AM_FUNC_STRTOD'
aclocal: /usr/share/aclocal/termios.m4: 5: duplicated macro
`AM_SYS_POSIX_TERMIOS'
aclocal: /usr/share/aclocal/winsz.m4: 5: duplicated macro
`AM_HEADER_TIOCGWINSZ_NEEDS_SYS_IOCTL'
error: Bad exit status from /var/tmp/rpm-tmp.1670 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.1670 (%build)
bash-2.05# rpm -qa | grep auto
autorpm-1.9.9-1
automake14-1.4p5-1
automake-1.4p5-2
autorun-2.65-1
autoconf213-2.13-4
autoconf-2.52-6
bash-2.05# ls Glide3-20010520-19.src.rpm
Glide3-20010520-19.src.rpm
bash-2.05#
Comment 1 Mike A. Harris 2002-08-16 02:51:40 EDT
I just bumped the release number, and rebuilt Glide3:

Glide3-20010520-20 DONE in dist-x.y-scratch by mharris@REDHAT.COM

Looks like your autoconf is messed up.  I'm leaving this open for now
though, in case your autoconf is messed up because of some screwup
on our end...

Let me know how you make out if you change anything and try again.
Comment 2 Mike A. Harris 2002-08-16 02:52:10 EDT
Adding autotools maestro to the CC list.
Comment 3 Alexandre Oliva 2002-08-16 03:06:58 EDT
I think the problem is that automake-1.4p5 breaks automake14-1.4p5, because
aclocal-1.4 looks for m4 macros in both /usr/share/aclocal-1.4 (where
automake14's macros go) and /usr/share/aclocal (where automake-1.4p5's macros
go).  When it finds more than one definition of a macro, it prints the very kind
of error you're seeing and gives up assuming something is wrong.
automake14-1.4p5 should have been marked as conflicting with automake-1.4p5, and
then you'd have been forced to upgrade your master automake to 1.5 or 1.6, which
would solve the problem (since their RPMS install macros in
/usr/share/aclocal-1.[56].
Please confirm that upgrading automake (but keeping automake14) fixes the problem.
Comment 4 Jens Petersen 2002-08-16 03:43:05 EDT
automake-1.4p6-2 will conflict with automake < 1.5, to prevent this kind
of problem from happening in the future.
Comment 5 Alexandre Oliva 2002-08-16 04:05:17 EDT
I hope you mean automake14-1.4p6-2.
Comment 6 Jens Petersen 2002-08-16 04:21:36 EDT
Yes, indeed. Fix is in automake14-1.4p6-2.  Thanks.
Comment 7 Mike A. Harris 2002-08-16 05:49:55 EDT
Bug set to MODIFIED state, please confirm the new autofooo packages
fix this problem for you.
Comment 8 R P Herrold 2002-08-16 14:31:50 EDT
Will test in a moment -- I think you are saying that the install sequence of the automake / automake14 is affecting this -- 

If so. this is a matter which it would seem, needs to be addressed in the post-inst scripts?

.... testing by re-building automake14-1.4p6-2

automake14-1.4.6-2 installed ...

=================================================

Mike -- I am frowning  <grin> ...


Requires: Glide3 = 20010520
Conflicts: XFree86-devel = 4.1.0
Wrote: /usr/src/redhat/SRPMS/Glide3-20010520-19.src.rpm
Wrote: /usr/src/redhat/RPMS/i386/Glide3-20010520-19.i386.rpm
Wrote: /usr/src/redhat/RPMS/i386/Glide3-devel-20010520-19.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.86943
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd Glide3
+ rm -rf /var/tmp/Glide3-20010520-root
+ exit 0
bash-2.05# rpm -Uvh  /usr/src/redhat/RPMS/i386/Glide3-20010520-19.i386.rpm /usr/src/redhat/RPMS/i386/Glide3-devel-20010520-19.i386.rpm
error: failed dependencies:
        XFree86-libs = 4.1.0 conflicts with Glide3-20010520-19
        XFree86-devel = 4.1.0 conflicts with Glide3-devel-20010520-19
bash-2.05# rpmbuild  -ba /usr/src/redhat/SPECS/XFree86.spec 
error: failed build dependencies:
        Glide3-devel >= 20010520 is needed by XFree86-4.2.0-62
bash-2.05# 

================================

much later ...

bash-2.05# rpm -e  XFree86-devel gtk+-devel imlib-devel gnome-libs-devel  libglade-devel gdk-pixbuf-devel
bash-2.05# rpm -Uvh /usr/src/redhat/RPMS/i386/Glide3-devel-20010520-19.i386.rpm 
Preparing...                ########################################### [100%]
   1:Glide3-devel           ########################################### [100%]
bash-2.05# rpmbuild  -ba /usr/src/redhat/SPECS/XFree86.spec 
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.44907
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf XFree86-4.2.0
+ /bin/mkdir -p XFree86-4.2.0
+ cd XFree86-4.2.0
+ /usr/bin/bzip2 -dc /usr/src/redhat/SOURCES/XFree86-4.2.0.tar.bz2
...
Comment 9 R P Herrold 2002-08-16 14:36:20 EDT
later in that process, another surfaces ... but as to Glide, I think we are OK to close ...

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=71690
Comment 10 Jens Petersen 2002-08-19 01:01:50 EDT
> I think you are saying that the install sequence of the automake / automake14
> is affecting this

Not the install order, but the package versions: you had two Automake 1.4
packages installed (automake14 and automake-1.4), which was causing the problem.
The solution being to either remove one of the offending automake 1.4 packages
or update the automake package to automake 1.5 or 1.6.x say, since
automake14 is a backward compatibility package, which is designed to be
installed with automake 1.5 and later.  The Conflicts directive in the new
automake14
package should prevent this problem from occuring from now on.

Note You need to log in before you can comment on or make changes to this bug.