Bug 7163 - C++ and g77 do not work
C++ and g77 do not work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: egcs (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-19 19:29 EST by Karl Larsen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 21:10:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File with a copy of the error message (940 bytes, text/plain)
1999-11-19 19:35 EST, Karl Larsen
no flags Details

  None (edit)
Description Karl Larsen 1999-11-19 19:29:36 EST
After I loaded the g77 rpm from the version 6.1 cheapbytes cd-rom neither
of the cross compilers work. The error message is the same with both and
involves a directory /usr/src/ba/.... which does not exist on my computer.
If needed I can send you the exact error message but not here.
Comment 1 Karl Larsen 1999-11-19 19:35:59 EST
Created attachment 9 [details]
File with a copy of the error message
Comment 2 Jeff Johnson 1999-12-15 12:51:59 EST
This is a bug in the egcs package which is incorrectly including links
into the Red Hat build dir.
Comment 3 Jim Kingdon 1999-12-23 15:00:59 EST
The fact that /usr/src/bs is mentioned probably is a red herring (that is,
I think it only appears in the error message; I don't think anything is
looking for a file there).  Now, as for the actual problem.  Off the top
of my head it looks like something strange is going on which is causing
the first character in MAIN__ and main to be omitted.  Can you offer any
more details about how to make this problem happen?  I've enclosed a
simple test of g77 which worked for me.

One nit: as far as I know, there is no cross compiler involved here
(that is, the "g77" which we ship is a native compiler - running on
a x86 and producing x86 code - whereas a cross compiler might
run on an x86 and produce code for, say, a PowerPC).

[kingdon@test114 6905]$ g77 -g foo.f
[kingdon@test114 6905]$ ./a.out
 Hello, world
[kingdon@test114 6905]$ cat foo.f
      PRINT *,'Hello, world'
      END
[kingdon@test114 6905]$
Comment 4 Cristian Gafton 2000-02-03 21:10:59 EST
closed due to lack of feedback

Note You need to log in before you can comment on or make changes to this bug.