Bug 716305 - Cannot install libvirt-qpid - missing dependencies
Summary: Cannot install libvirt-qpid - missing dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt-qpid
Version: 15
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 716308
TreeView+ depends on / blocked
 
Reported: 2011-06-23 21:59 UTC by Jan Stodola
Modified: 2011-06-24 17:56 UTC (History)
4 users (show)

Fixed In Version: libvirt-qpid-0.2.22-3.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-06-24 17:56:38 UTC


Attachments (Terms of Use)

Description Jan Stodola 2011-06-23 21:59:20 UTC
Description of problem:
yum fails to install libvirt-qpid because of missing dependencies:

[root@ibm-ls21-02 ~]# yum install libvirt-qpid
...
--> Finished Dependency Resolution
Error: Package: libvirt-qpid-0.2.22-1.fc15.x86_64 (fedora)
           Requires: libqpidcommon.so.3()(64bit)
           Available: qpid-cpp-client-0.8-4.fc15.1.x86_64 (fedora)
               libqpidcommon.so.3()(64bit)
           Available: qpid-cpp-client-0.10-2.fc15.i686 (updates)
               Not found
Error: Package: libvirt-qpid-0.2.22-1.fc15.x86_64 (fedora)
           Requires: libqmf.so.2()(64bit)
           Available: qmf-0.8-4.fc15.1.x86_64 (fedora)
               libqmf.so.2()(64bit)
Error: Package: libvirt-qpid-0.2.22-1.fc15.x86_64 (fedora)
           Requires: libqpidclient.so.3()(64bit)
           Available: qpid-cpp-client-0.8-4.fc15.1.x86_64 (fedora)
               libqpidclient.so.3()(64bit)
           Available: qpid-cpp-client-0.10-2.fc15.i686 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
libvirt-qpid-0.2.22-1.fc15.x86_64

How reproducible:
always

Steps to Reproduce:
1. install F15
2. yum install libvirt-qpid

Actual results:
missing dependencies, cannot install libvirt-qpid

Expected results:
installation without errors

Comment 1 Daniel Berrangé 2011-06-24 09:00:59 UTC
This was caused by a qpid updates which was pushed to stable with a ABI break :-(

https://admin.fedoraproject.org/updates/python-qpid-0.10-1.fc15,qpid-cpp-0.10-2.fc15

Comment 2 Fedora Update System 2011-06-24 09:01:40 UTC
libvirt-qpid-0.2.22-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libvirt-qpid-0.2.22-3.fc15

Comment 3 Fedora Update System 2011-06-24 17:56:33 UTC
libvirt-qpid-0.2.22-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.